summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartosz Golaszewski <bartosz.golaszewski@linaro.org>2023-01-25 09:17:31 +0100
committerKhem Raj <raj.khem@gmail.com>2023-01-25 08:57:42 -0800
commit12cdd958ef5b40b79c7317adf132242092df2b31 (patch)
tree9199d75ea676a149159936be04acfba50f97981a
parent290d4729e028a98f18d247f4cfb1fa371df43d1b (diff)
downloadmeta-openembedded-12cdd958ef5b40b79c7317adf132242092df2b31.tar.gz
libgpiod: fix python bindings build
It seems that automake's AM_PATH_PYTHON() macro no longer sets the $PYTHON variable. This means the python bindings build for libgpiod has been broken for some time. As we know which version we're using - python3 - let's hardcode it in configure.ac. For now add a patch that's been merged upstream and once a new bugfix release is out, we'll remove it. Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/libgpiod/files/0001-build-don-t-expect-automake-to-set-PYTHON.patch37
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libgpiod/files/0001-build-don-t-expect-automake-to-set-PYTHON.patch b/meta-oe/recipes-support/libgpiod/files/0001-build-don-t-expect-automake-to-set-PYTHON.patch
new file mode 100644
index 000000000..a3dc38188
--- /dev/null
+++ b/meta-oe/recipes-support/libgpiod/files/0001-build-don-t-expect-automake-to-set-PYTHON.patch
@@ -0,0 +1,37 @@
1From 3c461786feb1d5aa1ed2a911942a5f9fbc8b8086 Mon Sep 17 00:00:00 2001
2From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
3Date: Tue, 24 Jan 2023 17:38:43 +0100
4Subject: [libgpiod v1.6.x][PATCH] build: don't expect automake to set $PYTHON
5
6It seems that the implementation of AM_PATH_PYTHON() changed in automake
7recently and no longer sets $PYTHON variable which breaks the build on
8some systems.
9
10We know we use python3 so use python3-config explicitly.
11
12Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
13---
14Upstream-Status: Accepted
15
16 configure.ac | 4 ++--
17 1 file changed, 2 insertions(+), 2 deletions(-)
18
19diff --git a/configure.ac b/configure.ac
20index 3149384..0460810 100644
21--- a/configure.ac
22+++ b/configure.ac
23@@ -204,9 +204,9 @@ then
24 AC_MSG_ERROR([python3-config not found - needed for python bindings])
25 fi
26 AS_IF([test -z "$PYTHON_CPPFLAGS"],
27- [AC_SUBST(PYTHON_CPPFLAGS, [`$PYTHON-config --includes`])])
28+ [AC_SUBST(PYTHON_CPPFLAGS, [`python3-config --includes`])])
29 AS_IF([test -z "$PYTHON_LIBS"],
30- [AC_SUBST(PYTHON_LIBS, [`$PYTHON-config --libs`])])
31+ [AC_SUBST(PYTHON_LIBS, [`python3-config --libs`])])
32 fi
33
34 AC_CHECK_PROG([has_doxygen], [doxygen], [true], [false])
35--
362.37.2
37
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb b/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb
index 3e6e5d567..5164e7e02 100644
--- a/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb
+++ b/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb
@@ -7,6 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
7SRC_URI = " \ 7SRC_URI = " \
8 https://www.kernel.org/pub/software/libs/${BPN}/${BP}.tar.xz \ 8 https://www.kernel.org/pub/software/libs/${BPN}/${BP}.tar.xz \
9 file://run-ptest \ 9 file://run-ptest \
10 file://0001-build-don-t-expect-automake-to-set-PYTHON.patch \
10" 11"
11 12
12SRC_URI[md5sum] = "28e79f6f70fee1da9079558d8b7b3736" 13SRC_URI[md5sum] = "28e79f6f70fee1da9079558d8b7b3736"