diff options
author | Stefano Babic <sbabic@denx.de> | 2023-02-27 10:35:50 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-02-27 09:43:09 -0800 |
commit | 11108aaaf7dec77346eb7f858c5a9787700296f3 (patch) | |
tree | 40e4c9cb34157829dc3976ed5fc3a949774ce18c | |
parent | 45c05efdc95eb676071e3592ae3a167179bd0a2c (diff) | |
download | meta-openembedded-11108aaaf7dec77346eb7f858c5a9787700296f3.tar.gz |
zchunk: upgrade 1.2.4 -> 1.3.0
Release zchunk 1.3.0 with the following changes:
* meson: Use global function in argp check
* Add ZCK_NO_WRITE option to disable writing to a file
Signed-off-by: Stefano Babic <sbabic@denx.de>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/zchunk/files/clang.patch | 35 | ||||
-rw-r--r-- | meta-oe/recipes-support/zchunk/zchunk_1.3.0.bb (renamed from meta-oe/recipes-support/zchunk/zchunk_1.2.4.bb) | 5 |
2 files changed, 2 insertions, 38 deletions
diff --git a/meta-oe/recipes-support/zchunk/files/clang.patch b/meta-oe/recipes-support/zchunk/files/clang.patch deleted file mode 100644 index 86faf4aac..000000000 --- a/meta-oe/recipes-support/zchunk/files/clang.patch +++ /dev/null | |||
@@ -1,35 +0,0 @@ | |||
1 | From e69d907c3fe8765ce50ce1258648ebc8283ef8a7 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 22 Feb 2023 14:55:07 -0800 | ||
4 | Subject: [PATCH] meson: Use global function in argp check | ||
5 | |||
6 | clang is optimizing away parse_opt() since its marked static and not | ||
7 | used in main(), make life a bit harder for clang :) | ||
8 | removing static now emits the global symbols to be resolved during link | ||
9 | and when libargp is missing the error is thrown rightly | ||
10 | |||
11 | riscv64-yoe-linux-musl-ld: /tmp/a-5ba039.o: in function `.Lpcrel_hi0': | ||
12 | a.c:(.text+0x44): undefined reference to `argp_state_help' | ||
13 | clang-16: error: linker command failed with exit code 1 (use -v to see invocation) | ||
14 | |||
15 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
16 | |||
17 | Upstream-Status: Submitted [https://github.com/zchunk/zchunk/pull/92/] | ||
18 | Signed-off-by: Ross Burton <ross.burton@arm.com> | ||
19 | --- | ||
20 | meson.build | 2 +- | ||
21 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
22 | |||
23 | diff --git a/meson.build b/meson.build | ||
24 | index 3b92d58..ab54abd 100644 | ||
25 | --- a/meson.build | ||
26 | +++ b/meson.build | ||
27 | @@ -57,7 +57,7 @@ if host_machine.system() == 'windows' | ||
28 | endif | ||
29 | |||
30 | # argp-standalone dependency (if required) | ||
31 | -if build_machine.system() == 'windows' or build_machine.system() == 'darwin' or build_machine.system() == 'freebsd' or not cc.links('#include <argp.h>\nstatic error_t parse_opt (int key, char *arg, struct argp_state *state) { argp_usage(state); return 0; }; void main() {}') | ||
32 | +if build_machine.system() == 'windows' or build_machine.system() == 'darwin' or build_machine.system() == 'freebsd' or not cc.links('#include <argp.h>\nerror_t parse_opt (int key, char *arg, struct argp_state *state) { argp_usage(state); return 0; }; void main() {}') | ||
33 | argplib = cc.find_library('argp', has_headers : ['argp.h'], required: false) | ||
34 | if not argplib.found() | ||
35 | argplib = dependency('argp-standalone') | ||
diff --git a/meta-oe/recipes-support/zchunk/zchunk_1.2.4.bb b/meta-oe/recipes-support/zchunk/zchunk_1.3.0.bb index b4fd02760..07ab28375 100644 --- a/meta-oe/recipes-support/zchunk/zchunk_1.2.4.bb +++ b/meta-oe/recipes-support/zchunk/zchunk_1.3.0.bb | |||
@@ -4,10 +4,9 @@ AUTHOR = "Jonathan Dieter" | |||
4 | LICENSE = "BSD-2-Clause" | 4 | LICENSE = "BSD-2-Clause" |
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=daf6e68539f564601a5a5869c31e5242" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=daf6e68539f564601a5a5869c31e5242" |
6 | 6 | ||
7 | SRC_URI = "git://github.com/zchunk/zchunk.git;protocol=https;branch=main \ | 7 | SRC_URI = "git://github.com/zchunk/zchunk.git;protocol=https;branch=main" |
8 | file://clang.patch" | ||
9 | 8 | ||
10 | SRCREV = "0bed8496262a71beadccd4e562bdac093ef6e06f" | 9 | SRCREV = "1d8f14484b4e0b507487abe6c294fb2059b7b72f" |
11 | S = "${WORKDIR}/git" | 10 | S = "${WORKDIR}/git" |
12 | 11 | ||
13 | DEPENDS = "zstd" | 12 | DEPENDS = "zstd" |