summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2024-05-10 07:43:57 +0200
committerKhem Raj <raj.khem@gmail.com>2024-05-19 08:27:51 -0700
commit10d2bd01b34635fc86c7795999053115eb11ee83 (patch)
tree74a6474fc3f74b86e7111b64e0d453c0997fbd5d
parent36a1e36e1272ca50e5dba0c4cf25ee3ff8b8f1c9 (diff)
downloadmeta-openembedded-10d2bd01b34635fc86c7795999053115eb11ee83.tar.gz
flatpak: update 1.15.6 -> 1.15.8
- remove included patches - set path for fusermount3 to avoid requirement for fuse3-native. This is needed since: https://github.com/flatpak/flatpak/commit/2cb17b4eb82ecedaa98b5b7f954cf3e52fa95682 Changes in 1.15.8 ~~~~~~~~~~~~~~~~~ Security fixes: * Don't allow an executable name to be misinterpreted as a command-line option for bwrap(1). This prevents a sandbox escape where a malicious or compromised app could ask xdg-desktop-portal to generate a .desktop file with access to files outside the sandbox. (CVE-2024-32462) Other bug fixes: * Pass the -export-dynamic linker option as -Wl,-export-dynamic, fixing build failures with clang 18 and lld 18 (#5760) * Fix a double-free when installation is cancelled (#5763) * Fix installed-tests failure with "FUSERMOUNT: unbound variable" (#5751) * Translation updates: pt_BR (#5762), tr (#5761) Changes in 1.15.7 ~~~~~~~~~~~~~~~~~ Released: 2024-03-27 Dependencies: * The Meson build system is now required. Compiling with Autotools is no longer possible. * In distributions that compile Flatpak to use a separate bubblewrap (bwrap) executable, version 0.9.0 is recommended. Several of the bug fixes listed below will not be active if an older version is used. * In distributions that compile Flatpak to use a separate xdg-dbus-proxy executable, version 0.1.5 is recommended. * If libmalcontent (parental controls) is enabled, it must be version 0.5.0 or later. New features: * Automatically remove obsolete driver versions and other autopruned refs (#5632) * `--socket=inherit-wayland-socket` (#5614) * Automatically reload D-Bus session bus configuration after installing or upgrading apps, to pick up any exported D-Bus services (#3342) Bug fixes: * Update included copy of bubblewrap to version 0.9.0: * `--symlink` is now idempotent, meaning it succeeds if the symlink already exists and already has the desired target (#2387, #3477, #5255) * Report a better error message if `mount(2)` fails with `ENOSPC` * Fix a double-close on error reading from `--args`, `--seccomp` or `--add-seccomp-fd` argument * Improve memory allocation behaviour * Silence various compiler warnings * Update included copy of bubblewrap to version 0.1.5: * Fix handling of long object paths * Don't parse `<developer><name/></developer>` as the application name (#5700) * Don't refuse to start apps when there is no D-Bus system bus available (#5076) * Don't try to repeat migration of apps whose data was migrated to a new name and then deleted (#5668) * Improve handling of mixed locales on systems with systemd-localed (#5497) * Improve display of ellipsized columns in wide terminals (#5722) * Make `flatpak info -e` look for extensions in all installations (#5670) * Fix warnings from newer GLib versions (#5660, #5737) * Always set the `container` environment variable (#5610) * Always let the app inherit redirected file descriptors (#5626) * In `flatpak ps`, add xdg-desktop-portal-gnome to the list of backends we'll use to learn which apps are running in the background (#5729) * Don't use `WAYLAND_SOCKET` unless given `--socket=inherit-wayland-socket` (#5614) * Use `fusermount3` if compiled with FUSE 3, overridable with `-Dsystem_fusermount` compile-time option (#5104) * Avoid leaking a temporary variable from /etc/profile.d/flatpak.sh into the shell environment (#5574) * Improve async-signal safety (#5687) * Fix various memory leaks (#5683, #5690, #5691) * Avoid undefined behaviour of signed left-shift when storing object IDs in a hash table (#5738) * Detect the correct gtk-doc when cross-compiling (#5650) * Detect the correct wayland-scanner when cross-compiling (#5596) * Documentation improvements (#5659, #5677, #5682, #5664, #5719) * Skip more tests when FUSE isn't available (#5611) * Translation updates (#5602, #5707) Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/flatpak/flatpak/0001-meson.build-require-for-native-wayland-scanner.patch28
-rw-r--r--meta-oe/recipes-extended/flatpak/flatpak/0001-meson.build-require-native-gtkdoc.patch33
-rw-r--r--meta-oe/recipes-extended/flatpak/flatpak_1.15.8.bb (renamed from meta-oe/recipes-extended/flatpak/flatpak_1.15.6.bb)6
3 files changed, 3 insertions, 64 deletions
diff --git a/meta-oe/recipes-extended/flatpak/flatpak/0001-meson.build-require-for-native-wayland-scanner.patch b/meta-oe/recipes-extended/flatpak/flatpak/0001-meson.build-require-for-native-wayland-scanner.patch
deleted file mode 100644
index b076a3fff..000000000
--- a/meta-oe/recipes-extended/flatpak/flatpak/0001-meson.build-require-for-native-wayland-scanner.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From ced2e933cf647874da4baff002e0987b9bfe5fac Mon Sep 17 00:00:00 2001
2From: Markus Volk <f_l_k@t-online.de>
3Date: Sat, 18 Nov 2023 15:07:49 +0100
4Subject: [PATCH] meson.build: require for native wayland-scanner
5
6Signed-off-by: Markus Volk <f_l_k@t-online.de>
7
8Upstream-Status: Submitted [https://github.com/flatpak/flatpak/pull/5596]
9---
10 meson.build | 4 ++--
11 1 file changed, 1 insertions(+), 1 deletions(-)
12
13diff --git a/meson.build b/meson.build
14index f4e5b3a3..5d2f9eba 100644
15--- a/meson.build
16+++ b/meson.build
17@@ -207,7 +207,7 @@ gtkdoc_dep = dependency('gtk-doc', required : get_option('gtkdoc'))
18 build_gtk_doc = gtkdoc_dep.found()
19
20 wayland_client = dependency('wayland-client', required : get_option('wayland_security_context'))
21-wayland_scanner = dependency('wayland-scanner', version : '>= 1.15', required : get_option('wayland_security_context'))
22+wayland_scanner = dependency('wayland-scanner', version : '>= 1.15', required : get_option('wayland_security_context'), native : true)
23 wayland_protocols = dependency('wayland-protocols', version : '>= 1.32', required : get_option('wayland_security_context'))
24 build_wayland_security_context = wayland_client.found() and wayland_scanner.found() and wayland_protocols.found()
25
26--
272.42.0
28
diff --git a/meta-oe/recipes-extended/flatpak/flatpak/0001-meson.build-require-native-gtkdoc.patch b/meta-oe/recipes-extended/flatpak/flatpak/0001-meson.build-require-native-gtkdoc.patch
deleted file mode 100644
index 77b60ec98..000000000
--- a/meta-oe/recipes-extended/flatpak/flatpak/0001-meson.build-require-native-gtkdoc.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From 49737b1e4a74c77a8cd7ae727974d68503da087f Mon Sep 17 00:00:00 2001
2From: Markus Volk <f_l_k@t-online.de>
3Date: Fri, 12 Jan 2024 13:52:08 +0100
4Subject: [PATCH] meson.build: require native gtkdoc
5
6this fixes:
7| Run-time dependency gtk-doc found: NO (tried pkgconfig)
8|
9| ../git/meson.build:206:13: ERROR: Dependency "gtk-doc" not found, tried pkgconfig
10
11Upstream-Status: Submitted [https://github.com/flatpak/flatpak/pull/5650/commits/e5de3e46b917f830d7f81e9db6ed2a9b7d7db942]
12
13Signed-off-by: Markus Volk <f_l_k@t-online.de>
14---
15 meson.build | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/meson.build b/meson.build
19index f7f9372d..dccc3eb4 100644
20--- a/meson.build
21+++ b/meson.build
22@@ -203,7 +203,7 @@ appstream_dep = dependency('appstream', version : '>=0.12.0')
23 gdk_pixbuf_dep = dependency('gdk-pixbuf-2.0')
24 libseccomp_dep = dependency('libseccomp', required : get_option('seccomp'))
25 gir_dep = dependency('gobject-introspection-1.0', version : '>=1.40.0', required : get_option('gir'))
26-gtkdoc_dep = dependency('gtk-doc', required : get_option('gtkdoc'))
27+gtkdoc_dep = dependency('gtk-doc', required : get_option('gtkdoc'), native : true)
28 build_gtk_doc = gtkdoc_dep.found()
29
30 wayland_client = dependency('wayland-client', required : get_option('wayland_security_context'))
31--
322.43.0
33
diff --git a/meta-oe/recipes-extended/flatpak/flatpak_1.15.6.bb b/meta-oe/recipes-extended/flatpak/flatpak_1.15.8.bb
index 97e57c13d..8719d3ef0 100644
--- a/meta-oe/recipes-extended/flatpak/flatpak_1.15.6.bb
+++ b/meta-oe/recipes-extended/flatpak/flatpak_1.15.8.bb
@@ -6,11 +6,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
6SRC_URI = " \ 6SRC_URI = " \
7 gitsm://github.com/flatpak/flatpak;protocol=https;branch=main \ 7 gitsm://github.com/flatpak/flatpak;protocol=https;branch=main \
8 file://0001-flatpak-pc-add-pc_sysrootdir.patch \ 8 file://0001-flatpak-pc-add-pc_sysrootdir.patch \
9 file://0001-meson.build-require-for-native-wayland-scanner.patch \
10 file://0001-meson.build-require-native-gtkdoc.patch \
11" 9"
12 10
13SRCREV = "27b11b93c2a80a91c9461bc6c7f5e9a201406041" 11SRCREV = "925c80f913d69e7ca424428823e1431c4ffb0deb"
14 12
15S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
16 14
@@ -66,6 +64,8 @@ PACKAGECONFIG ?= " \
66 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland-security-context', '', d)} \ 64 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland-security-context', '', d)} \
67" 65"
68 66
67EXTRA_OEMESON = "-Dsystem_fusermount=${bindir}/fusermount3"
68
69FILES:${PN} += "${libdir} ${datadir}" 69FILES:${PN} += "${libdir} ${datadir}"
70 70
71USERADD_PACKAGES = "${PN}" 71USERADD_PACKAGES = "${PN}"