diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-04-01 09:14:12 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-06 13:00:29 +0200 |
commit | 10ad20d913202e2bdf5d341a73d44f317e4203b5 (patch) | |
tree | 01ffb5b6f7ce5c1f385b76ba3f6394c81b7b3fc1 | |
parent | 6c4caeee6f737e069c871a25110938b7a1e2332e (diff) | |
download | meta-openembedded-10ad20d913202e2bdf5d341a73d44f317e4203b5.tar.gz |
libuio: Fix build with musl
It needs fcntl.h which is indirectly included on glibc
append SRCPV to version
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-extended/libuio/libuio/0001-include-fcntl.h-for-O_RDWR-define.patch | 38 | ||||
-rw-r--r-- | meta-oe/recipes-extended/libuio/libuio_0.2.1.bb | 6 |
2 files changed, 43 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/libuio/libuio/0001-include-fcntl.h-for-O_RDWR-define.patch b/meta-oe/recipes-extended/libuio/libuio/0001-include-fcntl.h-for-O_RDWR-define.patch new file mode 100644 index 000000000..3cae5c992 --- /dev/null +++ b/meta-oe/recipes-extended/libuio/libuio/0001-include-fcntl.h-for-O_RDWR-define.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From d39c78d322585a32f9a55c67c25a99602ce08b12 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 1 Apr 2017 09:01:33 -0700 | ||
4 | Subject: [PATCH] include fcntl.h for O_RDWR define | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | tools/lsuio.c | 1 + | ||
9 | tools/rwuio.c | 1 + | ||
10 | 2 files changed, 2 insertions(+) | ||
11 | |||
12 | diff --git a/tools/lsuio.c b/tools/lsuio.c | ||
13 | index 58eb922..4769446 100644 | ||
14 | --- a/tools/lsuio.c | ||
15 | +++ b/tools/lsuio.c | ||
16 | @@ -19,6 +19,7 @@ | ||
17 | #include <stdio.h> | ||
18 | #include <sys/types.h> | ||
19 | #include <getopt.h> | ||
20 | +#include <fcntl.h> | ||
21 | |||
22 | #include "system.h" | ||
23 | #include "uio_helper.h" | ||
24 | diff --git a/tools/rwuio.c b/tools/rwuio.c | ||
25 | index aef9e90..ebc71e1 100644 | ||
26 | --- a/tools/rwuio.c | ||
27 | +++ b/tools/rwuio.c | ||
28 | @@ -20,6 +20,7 @@ | ||
29 | */ | ||
30 | #include <stdio.h> | ||
31 | #include <stdlib.h> | ||
32 | +#include <fcntl.h> | ||
33 | #include <sys/types.h> | ||
34 | #include <getopt.h> | ||
35 | |||
36 | -- | ||
37 | 2.12.1 | ||
38 | |||
diff --git a/meta-oe/recipes-extended/libuio/libuio_0.2.1.bb b/meta-oe/recipes-extended/libuio/libuio_0.2.1.bb index f4051977f..dd34c180a 100644 --- a/meta-oe/recipes-extended/libuio/libuio_0.2.1.bb +++ b/meta-oe/recipes-extended/libuio/libuio_0.2.1.bb | |||
@@ -4,12 +4,16 @@ LICENSE = "GPL-2.0" | |||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833" |
5 | 5 | ||
6 | SRC_URI = "git://git.code.sf.net/p/libuio/code \ | 6 | SRC_URI = "git://git.code.sf.net/p/libuio/code \ |
7 | file://replace_inline_with_static-inline.patch" | 7 | file://replace_inline_with_static-inline.patch \ |
8 | file://0001-include-fcntl.h-for-O_RDWR-define.patch \ | ||
9 | " | ||
8 | 10 | ||
9 | inherit autotools | 11 | inherit autotools |
10 | 12 | ||
11 | SRCREV = "ed4f07ea147ac403c28105ab44d01bbf524d36f9" | 13 | SRCREV = "ed4f07ea147ac403c28105ab44d01bbf524d36f9" |
12 | 14 | ||
15 | PV .= "+git${SRCPV}" | ||
16 | |||
13 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
14 | 18 | ||
15 | PACKAGES += "${PN}-tools" | 19 | PACKAGES += "${PN}-tools" |