summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2023-12-07 15:23:52 -0800
committerKhem Raj <raj.khem@gmail.com>2023-12-21 08:00:41 -0800
commit0b1b5efeb521fde8cd684605d21adba9db2e1bc9 (patch)
tree66f4fcf5a9187e8c1cdd282578e75abfa1aac63d
parente67a62b44c6ec6fa0d1f39076f58faf95b4cd0a3 (diff)
downloadmeta-openembedded-0b1b5efeb521fde8cd684605d21adba9db2e1bc9.tar.gz
python3-annotated-types: add v0.6.0
Run-time dependency for python3-pydantic """ PEP-593 added typing.Annotated as a way of adding context-specific metadata to existing types, and specifies that Annotated[T, x] should be treated as T by any tool or library without special logic for x. This package provides metadata objects which can be used to represent common constraints such as upper and lower bounds on scalar values and collection sizes, a Predicate marker for runtime checks, and descriptions of how we intend these metadata to be interpreted. In some cases, we also note alternative representations which do not require this package. """ References: https://peps.python.org/pep-0593/ Signed-off-by: Tim Orling <ticotimo@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-annotated-types_0.6.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-annotated-types_0.6.0.bb b/meta-python/recipes-devtools/python/python3-annotated-types_0.6.0.bb
new file mode 100644
index 000000000..79cbb66bc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-annotated-types_0.6.0.bb
@@ -0,0 +1,14 @@
1SUMMARY = "Reusable constraint types to use with typing.Annotated"
2DESCRIPTION = ""
3HOMEPAGE = ""
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c6afb13fdc220497ee5cded1e717ed67"
6
7SRC_URI[sha256sum] = "563339e807e53ffd9c267e99fc6d9ea23eb8443c08f112651963e24e22f84a5d"
8
9S = "${WORKDIR}/annotated_types-${PV}"
10PYPI_PACKAGE = "annotated_types"
11
12inherit pypi python_hatchling
13
14RDEPENDS:${PN} = "python3-typing-extensions"