summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-25 09:05:53 -0700
committerKhem Raj <raj.khem@gmail.com>2024-03-27 07:57:30 -0700
commit0a815da7bdb178169e046c29b37ce56b87a3f10e (patch)
treee62467c7d5b9c35ee5514e286b2f6066d4cea6a8
parent02b230b7f42a4009e082bac00b66c8d66691047a (diff)
downloadmeta-openembedded-0a815da7bdb178169e046c29b37ce56b87a3f10e.tar.gz
aer-inject: Fix build with latest musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/aer-inject/aer-inject/0001-include-libgen.h-for-basename.patch32
-rw-r--r--meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb3
2 files changed, 34 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/aer-inject/aer-inject/0001-include-libgen.h-for-basename.patch b/meta-oe/recipes-devtools/aer-inject/aer-inject/0001-include-libgen.h-for-basename.patch
new file mode 100644
index 000000000..358ff524e
--- /dev/null
+++ b/meta-oe/recipes-devtools/aer-inject/aer-inject/0001-include-libgen.h-for-basename.patch
@@ -0,0 +1,32 @@
1From a2ccd98076c2ac81830234555edf362ee19a337d Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 25 Mar 2024 09:00:41 -0700
4Subject: [PATCH] include libgen.h for basename
5
6basename prototype has been removed from string.h from latest musl [1]
7compilers e.g. clang-18 flags the absense of prototype as error. therefore
8include libgen.h for providing it.
9
10[1] https://git.musl-libc.org/cgit/musl/commit/?id=725e17ed6dff4d0cd22487bb64470881e86a92e7
11
12Upstream-Status: Submitted [Emailed patch to Author]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 aer-inject.c | 1 +
16 1 file changed, 1 insertion(+)
17
18diff --git a/aer-inject.c b/aer-inject.c
19index 74e7f72..eed1211 100644
20--- a/aer-inject.c
21+++ b/aer-inject.c
22@@ -11,6 +11,7 @@
23 */
24
25 #include <stdio.h>
26+#include <libgen.h>
27 #include <stdlib.h>
28 #include <string.h>
29 #include <fcntl.h>
30--
312.44.0
32
diff --git a/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb b/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb
index fbc6bdfbe..6a7699803 100644
--- a/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb
+++ b/meta-oe/recipes-devtools/aer-inject/aer-inject_1.0.bb
@@ -11,6 +11,7 @@ LICENSE = "GPL-2.0-only"
11LIC_FILES_CHKSUM = "file://README;beginline=25;endline=38;md5=643c2332ec702691a87ba6ea9499b2d6" 11LIC_FILES_CHKSUM = "file://README;beginline=25;endline=38;md5=643c2332ec702691a87ba6ea9499b2d6"
12 12
13SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/gong.chen/aer-inject.git;protocol=https;branch=master \ 13SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/gong.chen/aer-inject.git;protocol=https;branch=master \
14 file://0001-include-libgen.h-for-basename.patch \
14" 15"
15SRCREV = "9bd5e2c7886fca72f139cd8402488a2235957d41" 16SRCREV = "9bd5e2c7886fca72f139cd8402488a2235957d41"
16 17
@@ -26,4 +27,4 @@ do_install() {
26 oe_runmake 'DESTDIR=${D}' 'PREFIX=/usr/' install 27 oe_runmake 'DESTDIR=${D}' 'PREFIX=/usr/' install
27} 28}
28FILES:${PN} += "/usr/aer-inject" 29FILES:${PN} += "/usr/aer-inject"
29BBCLASSEXTEND = "native nativesdk" \ No newline at end of file 30BBCLASSEXTEND = "native nativesdk"