summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelipe F. Tonello <ftonello@cercacor.com>2013-03-01 18:23:46 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-03-13 17:21:52 +0100
commit0a7d88ea219ec5e8a966aaafe08662d288e6e760 (patch)
tree9e4211f46174c5a908ccf68cc6e1b956beda6730
parentbae744780d5abb612d7a4ed5bc5c321d48a1eabd (diff)
downloadmeta-openembedded-0a7d88ea219ec5e8a966aaafe08662d288e6e760.tar.gz
qextserialport: Added 1.2rc recipe
QExtSerialPort is a serial port library for Qt4/5. Signed-off-by: Felipe F. Tonello <ftonello@cercacor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-qt/qextserialport/qextserialport_1.2rc.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta-oe/recipes-qt/qextserialport/qextserialport_1.2rc.bb b/meta-oe/recipes-qt/qextserialport/qextserialport_1.2rc.bb
new file mode 100644
index 000000000..da6521583
--- /dev/null
+++ b/meta-oe/recipes-qt/qextserialport/qextserialport_1.2rc.bb
@@ -0,0 +1,55 @@
1DESCRIPTION = "Qt Ext Serial Port Library"
2HOMEPAGE = "http://http://code.google.com/p/qextserialport/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b866a28cda707ec714878bd933f46251"
5SECTION = "qt/libs"
6
7PR = "r0"
8
9# 1.2rc as version will sort lower then 1.2 when it's released
10REAL_PV = "1.2rc"
11PV = "1.1+${REAL_PV}"
12
13inherit qt4x11 pkgconfig
14
15DEPENDS = "udev"
16
17SRC_URI = " \
18 http://qextserialport.googlecode.com/files/qextserialport-${REAL_PV}.zip \
19"
20
21SRC_URI[md5sum] = "ffa061edb9f64666468d18402eee6108"
22SRC_URI[sha256sum] = "9cbee267aac9830f9944bb1d13872e51fba400aa9afe158e64f0fe265a0176bc"
23
24S = "${WORKDIR}/qextserialport-${REAL_PV}"
25
26FILES_${PN} = "${libdir}/libqextserialport${SOLIBS}"
27
28FILES_${PN}-dev = " \
29 ${libdir}/libqextserialport${SOLIBSDEV} \
30 ${libdir}/libqextserialport.prl \
31 ${includedir}/QtExtSerialPort/*.h \
32 ${datadir}/qt4/mkspecs/features/extserialport.prf \
33"
34
35FILES_${PN}-dbg += " \
36 ${libdir}/.debug/libqextserialport.so* \
37"
38
39do_configure_prepend() {
40 # based on the documentation, this line make sure we use udev in linux
41 cd ${S} && echo "linux*:CONFIG += qesp_linux_udev" > .qmake.cache
42
43 # Hacking hardcoded qmake variables
44 find *.pro -exec sed -i -e 's,$$\[QT_INSTALL_HEADERS\],${includedir},g' '{}' ';'
45 find *.pro -exec sed -i -e 's,$$\[QT_INSTALL_LIBS\],${libdir},g' '{}' ';'
46 find *.pro -exec sed -i -e 's,$$\[QMAKE_MKSPECS\],${datadir}/qt4/mkspecs/,g' '{}' ';'
47}
48
49do_install() {
50 export INSTALL_ROOT=${D}
51 oe_runmake install
52
53 # This is necessary to make it work with the qt based SDK
54 cd ${D}/${datadir}/qt4/mkspecs/features && sed -i -e "s|${STAGING_INCDIR_NATIVE}/qt4|\$(OE_QMAKE_INCDIR_QT)/..|" ./extserialport.prf
55}