summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-04-11 15:10:48 -0700
committerKhem Raj <raj.khem@gmail.com>2024-04-11 23:32:36 -0700
commit04eefd302d58c403e011ad34d1d346703a364a53 (patch)
tree03b4838d73d3a4a5d79997dda19ddc666fb53598
parent95f914bd5e02d72d09288127625ff8a8eeab6235 (diff)
downloadmeta-openembedded-04eefd302d58c403e011ad34d1d346703a364a53.tar.gz
libxml++: Delete recipe for 2.42.1
We already have libxml++-5 provided and some of the dependencies for libxml++ (older version of glibmm) are not available. Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/conf/include/ptest-packagelists-meta-oe.inc1
-rw-r--r--meta-oe/recipes-core/libxml/libxml++/libxml++_ptest.patch80
-rw-r--r--meta-oe/recipes-core/libxml/libxml++/run-ptest3
-rw-r--r--meta-oe/recipes-core/libxml/libxml++_2.42.1.bb35
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb1
5 files changed, 0 insertions, 120 deletions
diff --git a/meta-oe/conf/include/ptest-packagelists-meta-oe.inc b/meta-oe/conf/include/ptest-packagelists-meta-oe.inc
index 673b41f44..48f3412b7 100644
--- a/meta-oe/conf/include/ptest-packagelists-meta-oe.inc
+++ b/meta-oe/conf/include/ptest-packagelists-meta-oe.inc
@@ -65,7 +65,6 @@ PTESTS_PROBLEMS_META_OE ="\
65 libdbi-perl \ 65 libdbi-perl \
66 libjcat \ 66 libjcat \
67 libteam \ 67 libteam \
68 libxml++ \
69 oprofile \ 68 oprofile \
70 ostree \ 69 ostree \
71 psqlodbc \ 70 psqlodbc \
diff --git a/meta-oe/recipes-core/libxml/libxml++/libxml++_ptest.patch b/meta-oe/recipes-core/libxml/libxml++/libxml++_ptest.patch
deleted file mode 100644
index 2172c147c..000000000
--- a/meta-oe/recipes-core/libxml/libxml++/libxml++_ptest.patch
+++ /dev/null
@@ -1,80 +0,0 @@
1Upstream-Status: Pending
2
3--- a/Makefile.am
4+++ b/Makefile.am
5@@ -40,5 +40,8 @@ EXTRA_DIST = \
6 tools/conf_tests/have_exception_ptr.cc \
7 untracked/README
8
9+install-ptest:
10+ make -C examples install-ptest
11+
12 # Optional: auto-generate the ChangeLog file from the git log on make dist
13 include $(top_srcdir)/build/dist-changelog.am
14--- a/examples/Makefile.am
15+++ b/examples/Makefile.am
16@@ -19,6 +19,8 @@ AM_CPPFLAGS = -I$(top_builddir) -I$(top_
17 AM_CXXFLAGS = $(LIBXMLXX_WXXFLAGS)
18 LDADD = $(top_builddir)/libxml++/libxml++-$(LIBXMLXX_API_VERSION).la $(LIBXMLXX_LIBS)
19
20+LOG_DRIVER = $(SHELL) ../macros/test-driver
21+
22 check_PROGRAMS = \
23 dom_build/dom_build \
24 dom_parse_entities/dom_parse_entities \
25@@ -37,6 +39,23 @@ check_PROGRAMS = \
26 schemavalidation/schemavalidation \
27 textreader/textreader
28
29+check_DOTLIBS = \
30+ dom_build/.libs/dom_build \
31+ dom_parse_entities/.libs/dom_parse_entities \
32+ dom_parser/.libs/dom_parser \
33+ dom_parser_raw/.libs/dom_parser_raw \
34+ dom_read_write/.libs/dom_read_write \
35+ dom_xinclude/.libs/dom_xinclude \
36+ dom_xpath/.libs/dom_xpath \
37+ dtdvalidation/.libs/dtdvalidation \
38+ import_node/.libs/import_node \
39+ sax_exception/.libs/sax_exception \
40+ sax_parser/.libs/sax_parser \
41+ sax_parser_build_dom/.libs/sax_parser_build_dom \
42+ sax_parser_entities/.libs/sax_parser_entities \
43+ schemavalidation/.libs/schemavalidation \
44+ textreader/.libs/textreader
45+
46 # Shell scripts that call the example programs.
47 check_SCRIPTS = \
48 dom_build/make_check.sh \
49@@ -154,10 +173,10 @@ dist_noinst_DATA = \
50 # file are located in different directories.
51 dom_read_write/make_check.sh: Makefile
52 $(AM_V_GEN)echo '# Generated and used by "make check"' >$@
53- $(AM_V_at)echo 'dom_read_write/dom_read_write "$(srcdir)/dom_read_write/example.xml" dom_read_write/example_output.xml >/dev/null' >>$@
54+ $(AM_V_at)echo 'cd dom_read_write && .libs/dom_read_write "example.xml" example_output.xml >/dev/null' >>$@
55 $(AM_V_at)chmod +x $@
56
57-script_template = cd "$(srcdir)/<!progname!>" && "$(abs_builddir)/<!progname!>/<!progname!>" >/dev/null
58+script_template = cd "<!progname!>" && ".libs/<!progname!>" >/dev/null
59 standard_scripts = $(filter-out dom_read_write/make_check.sh,$(check_SCRIPTS))
60
61 # All other script files are generated like so:
62@@ -169,3 +188,18 @@ $(standard_scripts): Makefile
63 CLEANFILES = \
64 dom_read_write/example_output.xml \
65 $(check_SCRIPTS)
66+
67+buildtest: all
68+ $(MAKE) $(AM_MAKEFLAGS) $(check_PROGRAMS) $(check_SCRIPTS)
69+ $(MAKE) $(AM_MAKEFLAGS) buildtest-TESTS
70+
71+install-ptest:
72+ $(MKDIR_P) $(DESTDIR)/examples
73+ cp --parents $(check_DOTLIBS) $(DESTDIR)/examples
74+ cp --parents $(check_SCRIPTS) $(DESTDIR)/examples
75+ cd $(srcdir) && cp --parents $(dist_noinst_DATA) $(DESTDIR)/examples
76+ cp Makefile $(DESTDIR)/examples
77+ $(MKDIR_P) $(DESTDIR)/macros
78+ cp $(top_srcdir)/build/test-driver $(DESTDIR)/macros
79+ sed -i -e 's|^Makefile:|_Makefile:|' $(DESTDIR)/examples/Makefile
80+
diff --git a/meta-oe/recipes-core/libxml/libxml++/run-ptest b/meta-oe/recipes-core/libxml/libxml++/run-ptest
deleted file mode 100644
index 236f66753..000000000
--- a/meta-oe/recipes-core/libxml/libxml++/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2cd examples
3make -k check-TESTS
diff --git a/meta-oe/recipes-core/libxml/libxml++_2.42.1.bb b/meta-oe/recipes-core/libxml/libxml++_2.42.1.bb
deleted file mode 100644
index 7347e30f3..000000000
--- a/meta-oe/recipes-core/libxml/libxml++_2.42.1.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1SUMMARY = "C++ wrapper for libxml library"
2DESCRIPTION = "C++ wrapper for libxml library"
3HOMEPAGE = "http://libxmlplusplus.sourceforge.net"
4BUGTRACKER = "http://bugzilla.gnome.org/buglist.cgi?product=libxml%2B%2B"
5SECTION = "libs"
6LICENSE = "LGPL-2.1-or-later"
7LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 "
8
9SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
10SRC_URI = "${GNOME_MIRROR}/${BPN}/${SHRT_VER}/${BP}.tar.xz \
11 file://libxml++_ptest.patch \
12 file://run-ptest \
13"
14SRC_URI[sha256sum] = "9b59059abe5545d28ceb388a55e341095f197bd219c73e6623aeb6d801e00be8"
15
16DEPENDS = "libxml2 glibmm mm-common-native"
17
18inherit autotools pkgconfig ptest
19
20EXTRA_OECONF = "--disable-documentation"
21
22do_configure:prepend() {
23 mm-common-prepare --copy --force ${S}
24}
25
26do_compile_ptest() {
27 oe_runmake -C examples buildtest
28}
29
30PTEST_PARALLEL_MAKE = ""
31
32FILES:${PN}-doc += "${datadir}/devhelp"
33FILES:${PN}-dev += "${libdir}/libxml++-2.6/include/libxml++config.h"
34
35RDEPENDS:${PN}-ptest += "make"
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
index bc15373b6..8a63f5b20 100644
--- a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
@@ -184,7 +184,6 @@ RDEPENDS:packagegroup-meta-oe-core = "\
184 libnfc \ 184 libnfc \
185 libsigc++-2.0 \ 185 libsigc++-2.0 \
186 libsigc++-3 \ 186 libsigc++-3 \
187 libxml++ \
188 mdbus2 \ 187 mdbus2 \
189 distro-feed-configs \ 188 distro-feed-configs \
190 mm-common \ 189 mm-common \