summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 13:12:47 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:13 -0700
commit04493d62806de5bc2fae6edc8d7d0f0dd673c07a (patch)
tree831c479ace168224b48882ba9477cbcc29f12a9a
parent187ef9450c3495bac17494de6f0476b514eaba7b (diff)
downloadmeta-openembedded-04493d62806de5bc2fae6edc8d7d0f0dd673c07a.tar.gz
python-serpent: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-serpent.inc27
-rw-r--r--meta-python/recipes-devtools/python/python3-serpent_1.28.bb29
2 files changed, 27 insertions, 29 deletions
diff --git a/meta-python/recipes-devtools/python/python-serpent.inc b/meta-python/recipes-devtools/python/python-serpent.inc
deleted file mode 100644
index 676ea39de..000000000
--- a/meta-python/recipes-devtools/python/python-serpent.inc
+++ /dev/null
@@ -1,27 +0,0 @@
1SUMMARY = "Serialization based on ast.literal_eval"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://PKG-INFO;md5=5cd70632b6cdb96df9ddaf6a4ce619e6"
4
5SRC_URI[md5sum] = "15ef8b67c76a6d19bac9c16731a1e62a"
6SRC_URI[sha256sum] = "f306336ca09aa38e526f3b03cab58eb7e45af09981267233167bcf3bfd6436ab"
7
8inherit pypi ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS_${PN}-ptest += " \
15 ${PYTHON_PN}-pytest \
16 ${PYTHON_PN}-pytz \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
23
24RDEPENDS_${PN} += "\
25 ${PYTHON_PN}-netclient \
26 ${PYTHON_PN}-numbers \
27 "
diff --git a/meta-python/recipes-devtools/python/python3-serpent_1.28.bb b/meta-python/recipes-devtools/python/python3-serpent_1.28.bb
index 1e04def7b..af2d4aa4a 100644
--- a/meta-python/recipes-devtools/python/python3-serpent_1.28.bb
+++ b/meta-python/recipes-devtools/python/python3-serpent_1.28.bb
@@ -1,2 +1,27 @@
1inherit setuptools3 1SUMMARY = "Serialization based on ast.literal_eval"
2require python-serpent.inc 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://PKG-INFO;md5=5cd70632b6cdb96df9ddaf6a4ce619e6"
4
5SRC_URI[md5sum] = "15ef8b67c76a6d19bac9c16731a1e62a"
6SRC_URI[sha256sum] = "f306336ca09aa38e526f3b03cab58eb7e45af09981267233167bcf3bfd6436ab"
7
8inherit pypi ptest setuptools3
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS_${PN}-ptest += " \
15 ${PYTHON_PN}-pytest \
16 ${PYTHON_PN}-pytz \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
23
24RDEPENDS_${PN} += "\
25 ${PYTHON_PN}-netclient \
26 ${PYTHON_PN}-numbers \
27"