summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-25 10:15:41 -0700
committerKhem Raj <raj.khem@gmail.com>2024-03-25 10:58:12 -0700
commit025e589575690b74c3fbee5faaefd7babfa4b589 (patch)
treec1f04738e3596fc36609555aebcf78cc1176fd4c
parent371510307df97cfc04faa291ca1d736692aadb52 (diff)
downloadmeta-openembedded-025e589575690b74c3fbee5faaefd7babfa4b589.tar.gz
xfsdump: Fix build with musl >= 1.2.5
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-filesystems/recipes-utils/xfsdump/files/0001-include-libgen.h-for-basename-API-prototype.patch45
-rw-r--r--meta-filesystems/recipes-utils/xfsdump/xfsdump_3.1.12.bb1
2 files changed, 46 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/xfsdump/files/0001-include-libgen.h-for-basename-API-prototype.patch b/meta-filesystems/recipes-utils/xfsdump/files/0001-include-libgen.h-for-basename-API-prototype.patch
new file mode 100644
index 000000000..a44d3b7f3
--- /dev/null
+++ b/meta-filesystems/recipes-utils/xfsdump/files/0001-include-libgen.h-for-basename-API-prototype.patch
@@ -0,0 +1,45 @@
1From 45a532ad73b1ba27fc951657a33f39e8fa915765 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 25 Mar 2024 10:02:20 -0700
4Subject: [PATCH] include libgen.h for basename API prototype
5
6basename prototype has been removed from string.h from latest musl [1]
7compilers e.g. clang-18 flags the absense of prototype as error. therefore
8include libgen.h for providing it.
9
10[1] https://git.musl-libc.org/cgit/musl/commit/?id=725e17ed6dff4d0cd22487bb64470881e86a92e7
11
12Upstream-Status: Submitted [https://lore.kernel.org/linux-xfs/20240325170941.3279129-1-raj.khem@gmail.com/T/#u]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 common/main.c | 1 +
16 invutil/invidx.c | 1 +
17 2 files changed, 2 insertions(+)
18
19diff --git a/common/main.c b/common/main.c
20index 1db07d4..ca3b7d4 100644
21--- a/common/main.c
22+++ b/common/main.c
23@@ -16,6 +16,7 @@
24 * Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
25 */
26
27+#include <libgen.h>
28 #include <stdio.h>
29 #include <unistd.h>
30 #include <stdlib.h>
31diff --git a/invutil/invidx.c b/invutil/invidx.c
32index 5874e8d..c4e2e21 100644
33--- a/invutil/invidx.c
34+++ b/invutil/invidx.c
35@@ -19,6 +19,7 @@
36 #include <xfs/xfs.h>
37 #include <xfs/jdm.h>
38
39+#include <libgen.h>
40 #include <stdio.h>
41 #include <fcntl.h>
42 #include <unistd.h>
43--
442.44.0
45
diff --git a/meta-filesystems/recipes-utils/xfsdump/xfsdump_3.1.12.bb b/meta-filesystems/recipes-utils/xfsdump/xfsdump_3.1.12.bb
index 9e595b952..9c0394918 100644
--- a/meta-filesystems/recipes-utils/xfsdump/xfsdump_3.1.12.bb
+++ b/meta-filesystems/recipes-utils/xfsdump/xfsdump_3.1.12.bb
@@ -12,6 +12,7 @@ DEPENDS = "xfsprogs attr"
12 12
13SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsdump/${BP}.tar.xz \ 13SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsdump/${BP}.tar.xz \
14 file://remove-install-as-user.patch \ 14 file://remove-install-as-user.patch \
15 file://0001-include-libgen.h-for-basename-API-prototype.patch \
15 ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','file://0001-xfsdump-support-usrmerge.patch','',d)} \ 16 ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','file://0001-xfsdump-support-usrmerge.patch','',d)} \
16 " 17 "
17SRC_URI[sha256sum] = "f39c4c1b306b2dd7ec979c0e94d60fe69083d2ecf9af051cac5ef3bed772c74a" 18SRC_URI[sha256sum] = "f39c4c1b306b2dd7ec979c0e94d60fe69083d2ecf9af051cac5ef3bed772c74a"