diff options
author | Mingli Yu <mingli.yu@windriver.com> | 2022-04-24 16:45:38 +0800 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2022-05-03 06:58:49 -0700 |
commit | 72cc1b4f0a05330f6ebf90c9d26710ba720fcb10 (patch) | |
tree | eaf911993bbe631d32215ed1585a415ecb9bdf11 | |
parent | 786d3aa313e31a718acc9611ba3adb60573ec458 (diff) | |
download | meta-openembedded-hardknott-next.tar.gz |
makedumpfile: Upgrade to 1.6.9hardknott-next
* Linux 5.10 introduces a new lockless ringbuffer. The new ringbuffer
is structured completely different to the previous iterations.
Add support for retrieving the ringbuffer from debug information
and/or using vmcoreinfo. The new ringbuffer is detected based on
the availability of the "prb" symbol.
* Support newer kernels as follows:
- 5.10, 5.11, 5.12 (x86_64 SPARSEMEM)
Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r-- | meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch | 17 | ||||
-rw-r--r-- | meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.9.bb (renamed from meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.8.bb) | 2 |
2 files changed, 10 insertions, 9 deletions
diff --git a/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch b/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch index 270cc35625..94eac931e3 100644 --- a/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch +++ b/meta-oe/recipes-kernel/makedumpfile/makedumpfile/0001-makedumpfile-replace-hardcode-CFLAGS.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From af97e2ad643334b4c7c3d66f971ce9ebb2b596af Mon Sep 17 00:00:00 2001 | 1 | From 1053cf25be28b266ba264705e11179cf4f04aa91 Mon Sep 17 00:00:00 2001 |
2 | From: Mingli Yu <mingli.yu@windriver.com> | 2 | From: Mingli Yu <mingli.yu@windriver.com> |
3 | Date: Thu, 21 Jul 2016 18:06:21 +0800 | 3 | Date: Thu, 21 Jul 2016 18:06:21 +0800 |
4 | Subject: [PATCH] makedumpfile: replace hardcode CFLAGS | 4 | Subject: [PATCH] makedumpfile: replace hardcode CFLAGS |
@@ -13,14 +13,15 @@ Subject: [PATCH] makedumpfile: replace hardcode CFLAGS | |||
13 | Upstream-Status: Inappropriate[oe specific] | 13 | Upstream-Status: Inappropriate[oe specific] |
14 | 14 | ||
15 | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> | 15 | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> |
16 | |||
16 | --- | 17 | --- |
17 | Makefile | 45 +++++++++++++++++++++++---------------------- | 18 | Makefile | 45 +++++++++++++++++++++++---------------------- |
18 | 1 file changed, 23 insertions(+), 22 deletions(-) | 19 | 1 file changed, 23 insertions(+), 22 deletions(-) |
19 | 20 | ||
20 | Index: git/Makefile | 21 | diff --git a/Makefile b/Makefile |
21 | =================================================================== | 22 | index 6fa00bc..7aa7ae2 100644 |
22 | --- git.orig/Makefile | 23 | --- a/Makefile |
23 | +++ git/Makefile | 24 | +++ b/Makefile |
24 | @@ -8,12 +8,6 @@ ifeq ($(strip $CC),) | 25 | @@ -8,12 +8,6 @@ ifeq ($(strip $CC),) |
25 | CC = gcc | 26 | CC = gcc |
26 | endif | 27 | endif |
@@ -79,7 +80,7 @@ Index: git/Makefile | |||
79 | + -DRELEASE_DATE='"$(DATE)"' | 80 | + -DRELEASE_DATE='"$(DATE)"' |
80 | + | 81 | + |
81 | SRC_BASE = makedumpfile.c makedumpfile.h diskdump_mod.h sadump_mod.h sadump_info.h | 82 | SRC_BASE = makedumpfile.c makedumpfile.h diskdump_mod.h sadump_mod.h sadump_info.h |
82 | SRC_PART = print_info.c dwarf_info.c elf_info.c erase_info.c sadump_info.c cache.c tools.c | 83 | SRC_PART = print_info.c dwarf_info.c elf_info.c erase_info.c sadump_info.c cache.c tools.c printk.c |
83 | OBJ_PART=$(patsubst %.c,%.o,$(SRC_PART)) | 84 | OBJ_PART=$(patsubst %.c,%.o,$(SRC_PART)) |
84 | @@ -52,12 +53,12 @@ OBJ_ARCH=$(patsubst %.c,%.o,$(SRC_ARCH)) | 85 | @@ -52,12 +53,12 @@ OBJ_ARCH=$(patsubst %.c,%.o,$(SRC_ARCH)) |
85 | 86 | ||
@@ -104,7 +105,7 @@ Index: git/Makefile | |||
104 | +CFLAGS_COMMON += -DUSESNAPPY | 105 | +CFLAGS_COMMON += -DUSESNAPPY |
105 | endif | 106 | endif |
106 | 107 | ||
107 | LIBS := -lpthread $(LIBS) | 108 | LIBS := $(LIBS) -lpthread |
108 | @@ -90,14 +91,14 @@ LIBS := $(LIBS) $(call try-run,\ | 109 | @@ -90,14 +91,14 @@ LIBS := $(LIBS) $(call try-run,\ |
109 | all: makedumpfile | 110 | all: makedumpfile |
110 | 111 | ||
@@ -122,7 +123,7 @@ Index: git/Makefile | |||
122 | echo .TH MAKEDUMPFILE 8 \"$(DATE)\" \"makedumpfile v$(VERSION)\" \"Linux System Administrator\'s Manual\" > temp.8 | 123 | echo .TH MAKEDUMPFILE 8 \"$(DATE)\" \"makedumpfile v$(VERSION)\" \"Linux System Administrator\'s Manual\" > temp.8 |
123 | grep -v "^.TH MAKEDUMPFILE 8" $(VPATH)makedumpfile.8 >> temp.8 | 124 | grep -v "^.TH MAKEDUMPFILE 8" $(VPATH)makedumpfile.8 >> temp.8 |
124 | mv temp.8 makedumpfile.8 | 125 | mv temp.8 makedumpfile.8 |
125 | @@ -108,7 +109,7 @@ makedumpfile: $(SRC_BASE) $(OBJ_PART) $( | 126 | @@ -108,7 +109,7 @@ makedumpfile: $(SRC_BASE) $(OBJ_PART) $(OBJ_ARCH) |
126 | gzip -c ./makedumpfile.conf.5 > ./makedumpfile.conf.5.gz | 127 | gzip -c ./makedumpfile.conf.5 > ./makedumpfile.conf.5.gz |
127 | 128 | ||
128 | eppic_makedumpfile.so: extension_eppic.c | 129 | eppic_makedumpfile.so: extension_eppic.c |
diff --git a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.8.bb b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.9.bb index 6f87db1779..4350ea1261 100644 --- a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.8.bb +++ b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.9.bb | |||
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | |||
11 | LICENSE = "GPLv2.0" | 11 | LICENSE = "GPLv2.0" |
12 | 12 | ||
13 | SRCBRANCH ?= "master" | 13 | SRCBRANCH ?= "master" |
14 | SRCREV = "18e0cdba48feeccea2429b3b0b2691f4314d1062" | 14 | SRCREV = "a9ad811c15e769c8e6d8d915a05cebc32f2ea2f5" |
15 | 15 | ||
16 | DEPENDS = "bzip2 zlib elfutils xz" | 16 | DEPENDS = "bzip2 zlib elfutils xz" |
17 | RDEPENDS_${PN}-tools = "perl ${PN}" | 17 | RDEPENDS_${PN}-tools = "perl ${PN}" |