summaryrefslogtreecommitdiffstats
path: root/recipes-extended/safplus/safplus_6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/safplus/safplus_6.1.bb')
-rw-r--r--recipes-extended/safplus/safplus_6.1.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/recipes-extended/safplus/safplus_6.1.bb b/recipes-extended/safplus/safplus_6.1.bb
new file mode 100644
index 0000000..0f35a94
--- /dev/null
+++ b/recipes-extended/safplus/safplus_6.1.bb
@@ -0,0 +1,59 @@
1DESCRIPTION = "The canonical example of init scripts"
2SECTION = "base"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5PR = "r0"
6
7DEPENDS = "sqlite3 glib-2.0 gdbm"
8RDEPENDS_${PN} = "sqlite3 glib-2.0 gdbm"
9RPROVIDES_${PN} += "libClUtils.so libmw.so libClDbal.so"
10
11SRC_URI = "git://github.com/OpenClovis/SAFplus-Availability-Scalability-Platform"
12
13inherit autotools
14
15S = "${WORKDIR}/${BP}/src/SAFplus"
16
17OC_SDK = "${WORKDIR}/clovis"
18OC_ASP_BUILD = "${WORKDIR}/asp_build"
19
20OC_TARGET_DIR = "${prefix}/target/${TARGET_ARCH}/${TARGET_OS}"
21
22EXTRA_OECONF = " \
23 --with-sdk-dir=${OC_SDK} \
24 --with-safplus-build \
25 --without-snmp-build \
26 --prefix=${D}${prefix} \
27 "
28
29do_configure () {
30
31 mkdir -p ${OC_SDK}/6.1/sdk
32 mkdir -p ${OC_SDK}/6.1/buildtools/yocto
33 mkdir -p ${OC_ASP_BUILD}
34 cd ${OC_ASP_BUILD}
35
36 TARGET=${TARGET_OS} \
37 ARCH=${TARGET_ARCH} \
38 MARCH=${TARGET_ARCH} \
39 ${S}/configure ${EXTRA_OECONF}
40}
41
42do_compile () {
43
44 cd ${OC_ASP_BUILD}/asp/build/local
45 make
46
47}
48
49do_install () {
50 cd ${OC_ASP_BUILD}/asp/build/local
51 make safplus-install
52}
53
54INSANE_SKIP_${PN} += "dev-so libdir"
55INSANE_SKIP_${PN}-dbg += "libdir"
56
57FILES_${PN}-dbg += " ${OC_TARGET_DIR}/lib/.debug ${OC_TARGET_DIR}/lib/shared-*/.debug"
58FILES_${PN}-staticdev += " ${OC_TARGET_DIR}/lib/*.a"
59FILES_${PN} += " ${OC_TARGET_DIR}"