summaryrefslogtreecommitdiffstats
path: root/recipes-extended/openhpi-subagent/files/fix_autoconf.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/openhpi-subagent/files/fix_autoconf.patch')
-rw-r--r--recipes-extended/openhpi-subagent/files/fix_autoconf.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-extended/openhpi-subagent/files/fix_autoconf.patch b/recipes-extended/openhpi-subagent/files/fix_autoconf.patch
new file mode 100644
index 0000000..ad570c3
--- /dev/null
+++ b/recipes-extended/openhpi-subagent/files/fix_autoconf.patch
@@ -0,0 +1,38 @@
1diff -Naur openhpi-subagent-2.3.4-orig/acinclude.m4 openhpi-subagent-2.3.4/acinclude.m4
2--- openhpi-subagent-2.3.4-orig/acinclude.m4 2006-09-13 12:41:28.000000000 -0300
3+++ openhpi-subagent-2.3.4/acinclude.m4 2013-07-31 15:04:17.634435482 -0300
4@@ -54,9 +54,9 @@
5 ],
6 [
7 have_netsnmp=yes
8- SNMPFLAGS=`net-snmp-config --cflags | sed -e 's/-Wdeclaration-after-statement//g'`
9- SNMPALIBS=`net-snmp-config --agent-libs`
10- SNMPVERSIONOK=`net-snmp-config --version | awk -F\. '{ \
11+ SNMPFLAGS=`${net_snmp_config:-net-snmp-config} --cflags | sed -e 's/-Wdeclaration-after-statement//g'`
12+ SNMPALIBS=`${net_snmp_config:-net-snmp-config} --agent-libs`
13+ SNMPVERSIONOK=`${net_snmp_config:-net-snmp-config} --version | awk -F\. '{ \
14 if ( $[1] >= 5 ) { \
15 if ( $[2] > 0 ) print "OK"; \
16 if ( $[2] == 0) { \
17@@ -65,7 +65,7 @@
18 } \
19 }'`
20 # the following seems to work... thankfully.
21- SNMPCONFDIR=`net-snmp-config --configure-options | perl -p -e 's/.*sysconfdir=([\/\w]+).*/\1/'`
22+ SNMPCONFDIR=`${net_snmp_config:-net-snmp-config} --configure-options | perl -p -e 's/.*sysconfdir=([\/\w]+).*/\1/'`
23 if test "$SNMPVERSIONOK" == "OK"; then
24 AC_MSG_RESULT(yes)
25 else
26diff -Naur openhpi-subagent-2.3.4-orig/configure.ac openhpi-subagent-2.3.4/configure.ac
27--- openhpi-subagent-2.3.4-orig/configure.ac 2006-09-13 14:42:54.000000000 -0300
28+++ openhpi-subagent-2.3.4/configure.ac 2013-07-31 15:05:54.890438913 -0300
29@@ -95,6 +95,9 @@
30 ],
31 [OH_CHECK_FAIL(libopenhpiutils,openhpiutils-devel)])
32
33+AC_ARG_WITH(net-snmp-config,
34+ [[ --with-net-snmp-config=SCRIPT run SCRIPT as net-snmp-config]],
35+ [net_snmp_config=$withval])
36
37 OH_CHECK_NETSNMP
38