summaryrefslogtreecommitdiffstats
path: root/recipes-extended/openhpi-subagent/files/configure_pkgconfig_openhpiutils.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/openhpi-subagent/files/configure_pkgconfig_openhpiutils.patch')
-rw-r--r--recipes-extended/openhpi-subagent/files/configure_pkgconfig_openhpiutils.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-extended/openhpi-subagent/files/configure_pkgconfig_openhpiutils.patch b/recipes-extended/openhpi-subagent/files/configure_pkgconfig_openhpiutils.patch
new file mode 100644
index 0000000..c1e073b
--- /dev/null
+++ b/recipes-extended/openhpi-subagent/files/configure_pkgconfig_openhpiutils.patch
@@ -0,0 +1,38 @@
1Index: openhpi-subagent-2.3.4/configure.ac
2===================================================================
3--- openhpi-subagent-2.3.4.orig/configure.ac
4+++ openhpi-subagent-2.3.4/configure.ac
5@@ -65,14 +65,14 @@ fi
6
7 # uncomment the section below when libopenhpiutils
8 # has its own pkgconfig file 'openhpiutils.pc'
9-# HPIUTILS_LIBS=`pkg-config --libs openhpiutils`
10-# if test "x$HPIUTILS_LIBS" = "x"; then
11-# AC_MSG_ERROR([
12-# *** OpenHpiUtils pkgconfig file wasn't found
13-# *** we can't determine proper build flags without it
14-# *** please check your installation
15-# ])
16-# fi
17+HPIUTILS_LIBS=`pkg-config --libs openhpiutils`
18+if test "x$HPIUTILS_LIBS" = "x"; then
19+ AC_MSG_ERROR([
20+ *** OpenHpiUtils pkgconfig file wasn't found
21+ *** we can't determine proper build flags without it
22+ *** please check your installation
23+ ])
24+ fi
25
26 LIBS=$HPI_LIBS
27 # Checks for libraries
28@@ -90,8 +90,8 @@ AC_CHECK_LIB([openhpiutils], [oh_lookup_
29 have_hpiutils=yes
30 # uncomment the 2 lines below when openhpiutils
31 # has its own pkgconfig file 'openhpiutils.pc'
32-# HPIUTILS_FLAGS=`pkg-config --cflags openhpiutils`
33-# HPIUTILS_LIBS=`pkg-config --libs openhpiutils`
34+ HPIUTILS_FLAGS=`pkg-config --cflags openhpiutils`
35+ HPIUTILS_LIBS=`pkg-config --libs openhpiutils`
36 ],
37 [OH_CHECK_FAIL(libopenhpiutils,openhpiutils-devel)])
38