summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorLi xin <lixin.fnst@cn.fujitsu.com>2015-06-19 10:38:44 +0800
committerJoão Henrique Ferreira de Freitas <joaohf@gmail.com>2015-06-22 21:48:43 -0300
commitd7b1b9a17287fd715772cbf5c2b8e1356759a8ea (patch)
tree06997e80050ba5ecbb0feab6e96c9db6f481461d /recipes-extended
parent83b1f76a75266743dc9eb0238039d5b973ad8ac0 (diff)
downloadmeta-openclovis-d7b1b9a17287fd715772cbf5c2b8e1356759a8ea.tar.gz
openhpi: add systemd support
add systemd service file openhpid.service Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/openhpi/files/openhpid.service11
-rw-r--r--recipes-extended/openhpi/openhpi.inc13
-rw-r--r--recipes-extended/openhpi/openhpi_3.0.0.bb1
3 files changed, 24 insertions, 1 deletions
diff --git a/recipes-extended/openhpi/files/openhpid.service b/recipes-extended/openhpi/files/openhpid.service
new file mode 100644
index 0000000..a74713a
--- /dev/null
+++ b/recipes-extended/openhpi/files/openhpid.service
@@ -0,0 +1,11 @@
1[Unit]
2Description=OpenHPI daemon
3After=syslog.target
4
5[Service]
6Type=oneshot
7ExecStart=@SBINDIR@/openhpid -c @SYSCONFDIR@/openhpi/openhpi.conf
8RemainAfterExit=yes
9
10[Install]
11WantedBy=multi-user.target
diff --git a/recipes-extended/openhpi/openhpi.inc b/recipes-extended/openhpi/openhpi.inc
index 29015c3..975b6ce 100644
--- a/recipes-extended/openhpi/openhpi.inc
+++ b/recipes-extended/openhpi/openhpi.inc
@@ -14,12 +14,23 @@ DEPENDS = " \
14 14
15INC_PR = "r1" 15INC_PR = "r1"
16 16
17inherit autotools gettext update-alternatives pkgconfig 17inherit autotools gettext update-alternatives pkgconfig systemd
18 18
19PACKAGECONFIG ??= "net-snmp" 19PACKAGECONFIG ??= "net-snmp"
20 20
21PACKAGECONFIG[net-snmp] = "--with-net-snmp-config=${STAGING_BINDIR}/net-snmp-config,, net-snmp" 21PACKAGECONFIG[net-snmp] = "--with-net-snmp-config=${STAGING_BINDIR}/net-snmp-config,, net-snmp"
22 22
23SYSTEMD_SERVICE_${PN} = "openhpid.service"
24SYSTEMD_AUTO_ENABLE = "disable"
25
26do_install_append() {
27 install -d 777 ${D}/var/lib/openhpi
28 install -d ${D}/${systemd_unitdir}/system
29 install -m 644 ${WORKDIR}/openhpid.service ${D}/${systemd_unitdir}/system
30 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}/${systemd_unitdir}/system/openhpid.service
31 sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}/${systemd_unitdir}/system/openhpid.service
32}
33
23FILES_${PN} += "${libdir}/${PN}/*" 34FILES_${PN} += "${libdir}/${PN}/*"
24 35
25INSANE_SKIP_${PN} = "dev-so" 36INSANE_SKIP_${PN} = "dev-so"
diff --git a/recipes-extended/openhpi/openhpi_3.0.0.bb b/recipes-extended/openhpi/openhpi_3.0.0.bb
index b6a3509..fffead3 100644
--- a/recipes-extended/openhpi/openhpi_3.0.0.bb
+++ b/recipes-extended/openhpi/openhpi_3.0.0.bb
@@ -4,6 +4,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/openhpi/openhpi-${PV}.tar.gz \
4 file://openhpi_openclovis.patch \ 4 file://openhpi_openclovis.patch \
5 file://my_changes.patch \ 5 file://my_changes.patch \
6 file://xml.patch \ 6 file://xml.patch \
7 file://openhpid.service \
7 " 8 "
8SRC_URI[md5sum] = "9089cb59b732ff00b3805a1809405b4b" 9SRC_URI[md5sum] = "9089cb59b732ff00b3805a1809405b4b"
9SRC_URI[sha256sum] = "2af5f40040a1b99b0c0a60f1bc03505d3d51f5c445cd04b1f832eb060acbb227" 10SRC_URI[sha256sum] = "2af5f40040a1b99b0c0a60f1bc03505d3d51f5c445cd04b1f832eb060acbb227"