summaryrefslogtreecommitdiffstats
path: root/recipes-enea/partrt
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2015-10-28 13:30:10 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2015-10-28 13:30:10 +0100
commit38929ed6a4630d2b8f3efa00616800b4012ea0d7 (patch)
tree22bd8dca4994cd3d73f7f959f57f0bc7137d04cf /recipes-enea/partrt
downloadmeta-nfv-access-common-38929ed6a4630d2b8f3efa00616800b4012ea0d7.tar.gz
Initial commit
result of splitting up meta-enea Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'recipes-enea/partrt')
-rw-r--r--recipes-enea/partrt/partrt/run-ptest9
-rw-r--r--recipes-enea/partrt/partrt_1.1.bb30
2 files changed, 39 insertions, 0 deletions
diff --git a/recipes-enea/partrt/partrt/run-ptest b/recipes-enea/partrt/partrt/run-ptest
new file mode 100644
index 0000000..b84af18
--- /dev/null
+++ b/recipes-enea/partrt/partrt/run-ptest
@@ -0,0 +1,9 @@
1#!/bin/sh
2
3./test_partition.py target -v
4
5if [ $? -eq 0 ]; then
6 echo "PASS: test_partition"
7else
8 echo "FAIL: test_partition"
9fi
diff --git a/recipes-enea/partrt/partrt_1.1.bb b/recipes-enea/partrt/partrt_1.1.bb
new file mode 100644
index 0000000..8113805
--- /dev/null
+++ b/recipes-enea/partrt/partrt_1.1.bb
@@ -0,0 +1,30 @@
1SUMMARY = "CPU partitioning tool"
2DESCRIPTION = "partrt is a tool for dividing a SMP Linux system into a real time domain and a non-real time domain."
3SECTION = "utils"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b52bab7a403562f36be803f11489f1a4"
6
7RDEPENDS_${PN} = "bash"
8RDEPENDS_${PN}-ptest += "python"
9
10SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \
11 file://run-ptest \
12 "
13
14SRCREV = "cbe36a4946a2b3bb4927ca3b8ac800111ae9ce49"
15
16inherit ptest
17
18S = "${WORKDIR}/git"
19
20FILES_${PN} += "/bin/*"
21
22do_install() {
23 install -d ${D}/usr/bin
24 install ${S}/install/bin/partrt ${D}/usr/bin
25}
26
27do_install_ptest() {
28 install ${S}/test/test_partition.py ${D}${PTEST_PATH}
29 sed -i s/target/${MACHINE}/ ${D}${PTEST_PATH}/run-ptest
30}