summaryrefslogtreecommitdiffstats
path: root/recipes-enea/linx/linx-mod_2.6.7.bb
diff options
context:
space:
mode:
authorMartin Borg <martin.borg@enea.com>2016-02-22 14:09:57 +0100
committerNora Björklund <nora.bjorklund@enea.com>2016-02-29 13:50:52 +0100
commit7c0ab0937532741b31985ae908bcf6b0602bd8aa (patch)
tree788e6d48d95eaec978f8e86b964788e024cc5586 /recipes-enea/linx/linx-mod_2.6.7.bb
parent3f36f9ea3dc013cc3306017becccca70d4f5a314 (diff)
downloadmeta-nfv-access-common-7c0ab0937532741b31985ae908bcf6b0602bd8aa.tar.gz
linx: update to v.2.6.7
linx and linx-mod recipes updated to version 2.6.7. The patches we applied have been included in this release. Signed-off-by: Martin Borg <martin.borg@enea.com> Signed-off-by: Nora Björklund <nora.bjorklund@enea.com>
Diffstat (limited to 'recipes-enea/linx/linx-mod_2.6.7.bb')
-rw-r--r--recipes-enea/linx/linx-mod_2.6.7.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-enea/linx/linx-mod_2.6.7.bb b/recipes-enea/linx/linx-mod_2.6.7.bb
new file mode 100644
index 0000000..9bcf459
--- /dev/null
+++ b/recipes-enea/linx/linx-mod_2.6.7.bb
@@ -0,0 +1,30 @@
1SUMMARY = "LINX for Linux fast IPC"
2DESCRIPTION = "LINX is a distributed communication protocol stack for transparent inter node and interprocess communication for a heterogeneous mix of systems."
3HOMEPAGE = "http://linx.sourceforge.net/"
4
5SECTION = "kernel/modules"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://../../COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
9
10DEPENDS = "linux-libc-headers linx"
11RRECOMMENDS_${PN} = "linx kmod"
12
13SRC_URI = "http://linux.enea.com/linx/linx-${PV}.tar.gz"
14
15SRC_URI[md5sum] = "f9d7634faa2d7338e51418e2dca82875"
16SRC_URI[sha256sum] = "d047eb8d4b63ae385bf89dc3cc09854a0fe27f3f51c19dc332da7d40f9c0c28c"
17
18S = "${WORKDIR}/linx-${PV}/net/linx"
19
20inherit module
21
22module_do_compile_prepend () {
23
24 if [ -z $(cat ${STAGING_KERNEL_BUILDDIR}/.config | grep "CONFIG_MODULES=y") ] ; then
25 echo "The specified Linux kernel has no support for pluggable modules (CONFIG_MODULES=y). Enable it before baking this."
26 exit 1
27 fi
28
29 do_make_scripts
30}