summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/elfutils/elfutils/add-ptest.patch
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-11-10 10:54:05 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2015-11-10 13:47:30 +0100
commit2e4c80b695efdf3b9d48758f0ee0a05c95cb371e (patch)
treef30b8ca8e0c7676a84fbf59f11632b79aaacae62 /recipes-devtools/elfutils/elfutils/add-ptest.patch
parentfec5cd3b7ca6e593d7bf8a28711fd4d876354f05 (diff)
downloadmeta-nfv-access-common-2e4c80b695efdf3b9d48758f0ee0a05c95cb371e.tar.gz
elfutils: add ptest
Add Enea Specific ptest Signed-off-by: Tudor Florea <tudor.florea@enea.com> Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'recipes-devtools/elfutils/elfutils/add-ptest.patch')
-rw-r--r--recipes-devtools/elfutils/elfutils/add-ptest.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-devtools/elfutils/elfutils/add-ptest.patch b/recipes-devtools/elfutils/elfutils/add-ptest.patch
new file mode 100644
index 0000000..88f808d
--- /dev/null
+++ b/recipes-devtools/elfutils/elfutils/add-ptest.patch
@@ -0,0 +1,23 @@
1Add 'install-ptest' rule.
2
3Signed-off-by: Mihaela Sendrea <mihaela.sendrea@enea.com>
4Upstream-status: Pending
5---
6diff -uNr a/tests/Makefile.am b/tests/Makefile.am
7--- a/tests/Makefile.am 2013-08-19 14:05:23.256292155 +0200
8+++ b/tests/Makefile.am 2013-08-19 15:49:16.084543591 +0200
9@@ -240,3 +240,14 @@
10 coverage:
11 -$(srcdir)/coverage.sh
12 endif
13+
14+install-ptest:
15+ @$(MKDIR_P) $(DESTDIR)/tests
16+ @$(MKDIR_P) $(DESTDIR)/src
17+ @install $(builddir)/*$(EXEEXT) $(DESTDIR)/tests
18+ @install $(srcdir)/*.sh $(DESTDIR)/tests
19+ @install $(builddir)/../src/*$(EXEEXT) $(DESTDIR)/src
20+ @cp $(builddir)/../Makefile $(DESTDIR)
21+ @sed -i -e 's|^Makefile:|_Makefile:|' $(DESTDIR)/tests/Makefile
22+ @sed -i -e 's|$(srcdir)|.|' $(DESTDIR)/tests/Makefile
23+