summaryrefslogtreecommitdiffstats
path: root/images
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2015-10-28 13:30:10 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2015-10-28 13:30:10 +0100
commit38929ed6a4630d2b8f3efa00616800b4012ea0d7 (patch)
tree22bd8dca4994cd3d73f7f959f57f0bc7137d04cf /images
downloadmeta-nfv-access-common-38929ed6a4630d2b8f3efa00616800b4012ea0d7.tar.gz
Initial commit
result of splitting up meta-enea Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'images')
-rw-r--r--images/enea-image-base.bb5
-rw-r--r--images/enea-image-common.inc11
-rw-r--r--images/enea-image-featured.bb76
3 files changed, 92 insertions, 0 deletions
diff --git a/images/enea-image-base.bb b/images/enea-image-base.bb
new file mode 100644
index 0000000..41eba70
--- /dev/null
+++ b/images/enea-image-base.bb
@@ -0,0 +1,5 @@
1DESCRIPTION = "console only image that fully suport target HW"
2require enea-image-common.inc
3
4IMAGE_ROOTFS_EXTRA_SPACE = "131072"
5IMAGE_OVERHEAD_FACTOR = "2"
diff --git a/images/enea-image-common.inc b/images/enea-image-common.inc
new file mode 100644
index 0000000..2f063eb
--- /dev/null
+++ b/images/enea-image-common.inc
@@ -0,0 +1,11 @@
1IMAGE_FEATURES += "ssh-server-dropbear package-management"
2
3IMAGE_INSTALL = " \
4 packagegroup-enea-core-boot \
5 "
6
7IMAGE_LINGUAS = ""
8
9LICENSE = "MIT"
10
11inherit core-image
diff --git a/images/enea-image-featured.bb b/images/enea-image-featured.bb
new file mode 100644
index 0000000..2d22237
--- /dev/null
+++ b/images/enea-image-featured.bb
@@ -0,0 +1,76 @@
1DESCRIPTION = "Full featured image with full target support"
2require enea-image-common.inc
3
4IMAGE_FEATURES[validitems] += "read-only-rootfs empty-root-password allow-empty-password post-install-logging "
5
6IMAGE_FEATURES += " \
7 dbg-pkgs \
8 debug-tweaks \
9 dev-pkgs \
10 doc-pkgs \
11 ptest-pkgs \
12 splash \
13 staticdev-pkgs \
14 eclipse-debug \
15 hwcodecs \
16 nfs-server \
17 qt4-pkgs \
18 ssh-server-openssh \
19 tools-debug \
20 tools-profile \
21 tools-sdk \
22 tools-testapps \
23 x11 \
24 x11-base"
25
26IMAGE_INSTALL = " \
27 packagegroup-base \
28 packagegroup-enea-debug \
29 packagegroup-enea-rt-tools \
30 packagegroup-enea-ptest \
31 packagegroup-enea-ddt \
32 packagegroup-enea-sys \
33 packagegroup-enea-bench \
34 ${ROOTFS_PKGMANAGE_BOOTSTRAP} \
35 beecrypt \
36 binutils \
37 chkconfig \
38 cracklib \
39 curl \
40 dhcp-client \
41 eventlog \
42 file \
43 findutils \
44 freetype \
45 fuse \
46 gawk \
47 gcc \
48 gnutls \
49 grep \
50 gzip \
51 icu \
52 insserv \
53 kbd \
54 kernel-modules \
55 libgcrypt \
56 libgpg-error \
57 libtasn1 \
58 lsb \
59 lsbinitscripts \
60 mingetty \
61 openssh \
62 ossp-uuid \
63 perf \
64 pkgconfig \
65 procps \
66 psmisc \
67 rpm \
68 rt-bmark \
69 tar \
70 tipcutils \
71 udev-extraconf \
72 zip \
73 "
74
75IMAGE_ROOTFS_EXTRA_SPACE = "1048576"
76IMAGE_OVERHEAD_FACTOR = "1.5"