summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandru Avadanii <Alexandru.Avadanii@enea.com>2021-04-13 17:55:41 +0200
committerAdrian Calianu <Adrian.Calianu@enea.com>2021-05-11 12:27:50 +0200
commite98476fdbdd0b7de57dbe4ef3005a897ac431f26 (patch)
tree273c3b17bfc302f8326f65e14858c9a0a80ba44d
parent04993615a7c6c5832907cd9a9d0d4bfbb0bdc67a (diff)
downloadmeta-nfv-access-common-e98476fdbdd0b7de57dbe4ef3005a897ac431f26.tar.gz
partrt, bitcalc, count-ticks: Bump, fixes
- bump all 3 recipes to the latest upstream commit to include python3 compatibility changes in partrt; - partrt: add missing 'bitcalc' RDEPENDS; - minor cleanup; Signed-off-by: Alexandru Avadanii <Alexandru.Avadanii@enea.com> Change-Id: I1c4874eb8a2a02d0443f0ba873ce5df2e95d5a8f
-rw-r--r--recipes-enea/bitcalc/bitcalc_1.0.bb8
-rw-r--r--recipes-enea/count-ticks/count-ticks_1.1.bb6
-rw-r--r--recipes-enea/partrt/partrt_1.1.bb9
3 files changed, 11 insertions, 12 deletions
diff --git a/recipes-enea/bitcalc/bitcalc_1.0.bb b/recipes-enea/bitcalc/bitcalc_1.0.bb
index f5a0aad..d822729 100644
--- a/recipes-enea/bitcalc/bitcalc_1.0.bb
+++ b/recipes-enea/bitcalc/bitcalc_1.0.bb
@@ -19,10 +19,14 @@ SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \
19DEPENDS_remove_aarch64 = "gcc-sanitizers" 19DEPENDS_remove_aarch64 = "gcc-sanitizers"
20SRC_URI_append_aarch64 = "file://0001-bitcalc-disable-gcc-address-sanitizer.patch" 20SRC_URI_append_aarch64 = "file://0001-bitcalc-disable-gcc-address-sanitizer.patch"
21 21
22SRCREV = "9d4d1ce26b58ada516466c30e53c75c2961d6f0a" 22SRCREV = "a96dcc47f327a990afaf75911183b1631367609c"
23 23
24S = "${WORKDIR}/git" 24S = "${WORKDIR}/git"
25 25
26EXTRA_OEMAKE += "'DESTDIR=${D}/usr/bin'" 26EXTRA_OEMAKE += "'DESTDIR=${D}${bindir}'"
27 27
28inherit pkgconfig cmake 28inherit pkgconfig cmake
29
30do_install() {
31 install -m 0755 -D ${B}/bitcalc/src/bitcalc ${D}${bindir}/bitcalc
32}
diff --git a/recipes-enea/count-ticks/count-ticks_1.1.bb b/recipes-enea/count-ticks/count-ticks_1.1.bb
index a33a0f9..1a66f3b 100644
--- a/recipes-enea/count-ticks/count-ticks_1.1.bb
+++ b/recipes-enea/count-ticks/count-ticks_1.1.bb
@@ -12,14 +12,12 @@ SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \
12 file://run-ptest \ 12 file://run-ptest \
13 " 13 "
14 14
15SRCREV = "9d4d1ce26b58ada516466c30e53c75c2961d6f0a" 15SRCREV = "a96dcc47f327a990afaf75911183b1631367609c"
16 16
17inherit ptest 17inherit ptest
18 18
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
20 20
21FILES_${PN} += "/bin/*"
22
23do_install() { 21do_install() {
24 install -D ${S}/count_ticks/count_ticks ${D}/usr/bin/count_ticks 22 install -m 0755 -D ${S}/count_ticks/count_ticks ${D}${bindir}/count_ticks
25} 23}
diff --git a/recipes-enea/partrt/partrt_1.1.bb b/recipes-enea/partrt/partrt_1.1.bb
index 65995e1..4509002 100644
--- a/recipes-enea/partrt/partrt_1.1.bb
+++ b/recipes-enea/partrt/partrt_1.1.bb
@@ -4,24 +4,21 @@ SECTION = "utils"
4LICENSE = "BSD" 4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b52bab7a403562f36be803f11489f1a4" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=b52bab7a403562f36be803f11489f1a4"
6 6
7RDEPENDS_${PN} = "bash" 7RDEPENDS_${PN} = "bash bitcalc"
8RDEPENDS_${PN}-ptest += "python3" 8RDEPENDS_${PN}-ptest += "python3"
9 9
10SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \ 10SRC_URI = "git://github.com/OpenEneaLinux/rt-tools.git;branch=master \
11 file://run-ptest \ 11 file://run-ptest \
12 " 12 "
13 13
14SRCREV = "9d4d1ce26b58ada516466c30e53c75c2961d6f0a" 14SRCREV = "a96dcc47f327a990afaf75911183b1631367609c"
15 15
16inherit ptest 16inherit ptest
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19 19
20FILES_${PN} += "/bin/*"
21
22do_install() { 20do_install() {
23 install -d ${D}/usr/bin 21 install -m 0755 -D ${S}/partrt/partrt ${D}${bindir}/partrt
24 install ${S}/partrt/partrt ${D}/usr/bin
25} 22}
26 23
27do_install_ptest() { 24do_install_ptest() {