summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-intel.inc29
1 files changed, 21 insertions, 8 deletions
diff --git a/recipes-kernel/linux/linux-intel.inc b/recipes-kernel/linux/linux-intel.inc
index dd677f3..1a1edbc 100644
--- a/recipes-kernel/linux/linux-intel.inc
+++ b/recipes-kernel/linux/linux-intel.inc
@@ -4,18 +4,31 @@ require recipes-kernel/linux/linux-intel_5.10.bb
4require recipes-kernel/linux/linux-deploy-kconfig.inc 4require recipes-kernel/linux/linux-deploy-kconfig.inc
5require recipes-kernel/linux/linux-common-config.inc 5require recipes-kernel/linux/linux-common-config.inc
6 6
7SRCREV_metaenea = "c930040f777c2546033b3fc55b475c0792ac62e9" 7# Note: these should be removed to bump kernel back to v5.10.78
8KENEABRANCH = "intel-5.10" 8SRC_URI_remove = " \
9SRC_URI_append = " git://git@git.enea.com/linux/enea-kernel-cache.git;protocol=ssh;type=kmeta;name=metaenea;branch=${KENEABRANCH};destsuffix=enea-kernel-meta" 9 file://0001-io-mapping-Cleanup-atomic-iomap.patch \
10 10"
11# Upstream BSPs include aufs support (by patching the kernel source + enabling it in kernel config). 11
12# However, our current kernel version contains a backported commit that conflicts with aufs patches. 12LINUX_VERSION = "5.10.35"
13# Until aufs patches are rebased in yocto-kernel-cache, disable aufs kernel source patching, since 13SRCREV_machine = "0fd9e7f81ac665d77c40d5c4a3815e46d4d07e90"
14# we don't enable it via kernel config anyway. 14SRCREV_meta = "cd049697e9b2d3e9118110d476075ff8f87202cc"
15
16SRCREV_metaenea = "${AUTOREV}"
17SRC_URI_append = " git://${COREBASE}/../src/enea-kernel-cache;protocol=file;usehead=1;type=kmeta;name=metaenea;destsuffix=enea-kernel-meta"
18
15do_kernel_metadata_prepend() { 19do_kernel_metadata_prepend() {
16 ## ENEA_start ## 20 ## ENEA_start ##
17 # kernel-meta patching via patch files added to SRC_URI is currently broken, handle it here 21 # kernel-meta patching via patch files added to SRC_URI is currently broken, handle it here
22
23 # Upstream BSPs include aufs support (by patching the kernel source + enabling it in kernel config).
24 # However, our current kernel version contains a backported commit that conflicts with aufs patches.
25 # Until aufs patches are rebased in yocto-kernel-cache, disable aufs kernel source patching, since
26 # we don't enable it via kernel config anyway.
18 sed -i -E 's/^(include features.aufs.*)$/# \1/g' ${WORKDIR}/kernel-meta/ktypes/standard/standard.scc 27 sed -i -E 's/^(include features.aufs.*)$/# \1/g' ${WORKDIR}/kernel-meta/ktypes/standard/standard.scc
28
29 # Upstream yocto-kernel-cache adds a backported patch that meanwhile got upstreamed, but was not
30 # yet removed, causing patching conflicts. Until upstream cleans up this mess, handle it here.
31 sed -i -E 's/^(patch cgroup1-fix-leaked.*)$/# \1/g' ${WORKDIR}/kernel-meta/patches/misc/misc.scc
19 ## ENEA_end ## 32 ## ENEA_end ##
20} 33}
21 34