summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandru Avadanii <Alexandru.Avadanii@enea.com>2021-07-06 17:25:26 +0200
committerAlexandru Avadanii <Alexandru.Avadanii@enea.com>2021-07-06 17:28:19 +0200
commit1a86d672f02f0fa29ac4113fc3d1b676460350c6 (patch)
tree9ef90536d657438c3911d3b35c3f9e7f5d8c2024
parenta3c670b9dd28073713e8e0b6f75aed77f35fade0 (diff)
downloadmeta-nfv-access-bsp-x86-1a86d672f02f0fa29ac4113fc3d1b676460350c6.tar.gz
linux-intel: Allow using "63" as alias for "last"
Previous Enea Edge releases hardcode the kernel args in a way that cannot currently be changed on upgrade. Due to upstream changes in the kernel, specifying a non-existent CPU, e.g. greater than the number of the last CPU is no longer supported and leads to nohz_full, isolcpus, rcu_nocbs no longer being honored. Until we have a proper mechanism in place that will allow specifying kernel arguments per-boot-entry; we alias "63" to "last", so that expressions like "1-63" are equivalent to "1-last". This will ensure backwards compatibility with kernel 4.14 arguments. Note: This relies on the assumption that we don't support boards with more than 64 cores and should be removed as soon as per-boot-entry kernel args are supported. Change-Id: I21d99315192ea4dc224f11314557e0a5ed1b34b6 Signed-off-by: Alexandru Avadanii <Alexandru.Avadanii@enea.com>
-rw-r--r--recipes-kernel/linux/linux-intel.inc5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-intel.inc b/recipes-kernel/linux/linux-intel.inc
index 48a1894..685984c 100644
--- a/recipes-kernel/linux/linux-intel.inc
+++ b/recipes-kernel/linux/linux-intel.inc
@@ -4,7 +4,7 @@ require recipes-kernel/linux/linux-intel_5.10.bb
4require recipes-kernel/linux/linux-deploy-kconfig.inc 4require recipes-kernel/linux/linux-deploy-kconfig.inc
5require recipes-kernel/linux/linux-common-config.inc 5require recipes-kernel/linux/linux-common-config.inc
6 6
7SRCREV_metaenea = "8dc3b0976651277b49123ab7cdf7ffe5bd250f8d" 7SRCREV_metaenea = "f86788bac0c8aaa0903aa2ef3b98ec0327a56d5b"
8KENEABRANCH = "intel-5.10" 8KENEABRANCH = "intel-5.10"
9SRC_URI_append = " git://git@git.enea.com/linux/enea-kernel-cache.git;protocol=ssh;type=kmeta;name=metaenea;branch=${KENEABRANCH};destsuffix=enea-kernel-meta" 9SRC_URI_append = " git://git@git.enea.com/linux/enea-kernel-cache.git;protocol=ssh;type=kmeta;name=metaenea;branch=${KENEABRANCH};destsuffix=enea-kernel-meta"
10 10
@@ -56,6 +56,9 @@ KERNEL_FEATURES_append = " features/ipmi/ipmi_ssif.scc"
56# ACPI Tiny power button 56# ACPI Tiny power button
57KERNEL_FEATURES_append = " features/acpi/acpi_tiny_pwrbtn_y.scc" 57KERNEL_FEATURES_append = " features/acpi/acpi_tiny_pwrbtn_y.scc"
58 58
59# CPULIST: Allow using "63" as an alias for "last" in nohz_full, isolcpus etc.
60KERNEL_FEATURES_append = " features/cpulist_abbrev/cpulist_abbrev_enea.scc"
61
59# IPv4 waiting for carrier on 62# IPv4 waiting for carrier on
60KERNEL_FEATURES_append = " patches/ipv4/ipv4wait.scc" 63KERNEL_FEATURES_append = " patches/ipv4/ipv4wait.scc"
61 64