summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2021-11-12 14:02:57 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-13 16:12:09 +0000
commit992fb40bdbfe9fe60f815aac46e04c58963918b5 (patch)
treeb36cfb1d0fa55baf8f1138af754ba9cb39c2bb15
parent585b6b8ec444b92ed310109f9f5ddf08269d9ce0 (diff)
downloadmeta-mingw-992fb40bdbfe9fe60f815aac46e04c58963918b5.tar.gz
dtc: update for recipe changes in oe-core3.5_M1
The tools now build for MinGW so we don't need to disable them, but as ncurses still fails we should continue to remove the bash RDEPENDS. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--recipes-core/dtc/dtc_%.bbappend15
1 files changed, 0 insertions, 15 deletions
diff --git a/recipes-core/dtc/dtc_%.bbappend b/recipes-core/dtc/dtc_%.bbappend
index 2d27a0a..b71c46b 100644
--- a/recipes-core/dtc/dtc_%.bbappend
+++ b/recipes-core/dtc/dtc_%.bbappend
@@ -1,16 +1 @@
1
2do_configure:append:mingw32 () {
3 # don't try to build the other dtc components when installing libs
4 sed -i 's/install-lib: all/install-lib: libfdt/g' ${S}/Makefile
5}
6
7do_compile:mingw32 () {
8 oe_runmake libfdt
9}
10
11do_install:mingw32 () {
12 oe_runmake install-lib install-includes
13}
14
15RDEPENDS:${PN}-misc:remove:mingw32 = "bash" RDEPENDS:${PN}-misc:remove:mingw32 = "bash"
16