summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Watt <JPEWhacker@gmail.com>2021-06-16 09:50:07 -0500
committerJoshua Watt <JPEWhacker@gmail.com>2021-06-16 09:50:07 -0500
commit6bc07522fa7cee5f705411bdc1eb35d312938453 (patch)
tree609adb01ed715a0afe658f5d049a5dfb7cbb217f
parentbfd22a248c0db4c57d5a72d675979d8341a7e9c1 (diff)
downloadmeta-mingw-6bc07522fa7cee5f705411bdc1eb35d312938453.tar.gz
Disable debuginfod
Disables debuginfod when using MingGW. This feature brings in unbuildable dependencies and can't be used. Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
-rw-r--r--conf/machine-sdk/include/mingw32-common.inc2
-rw-r--r--recipes-devtools/gdb/gdb-cross-canadian_%.bbappend1
2 files changed, 3 insertions, 0 deletions
diff --git a/conf/machine-sdk/include/mingw32-common.inc b/conf/machine-sdk/include/mingw32-common.inc
index 0109e75..3997a26 100644
--- a/conf/machine-sdk/include/mingw32-common.inc
+++ b/conf/machine-sdk/include/mingw32-common.inc
@@ -15,6 +15,8 @@ USE_NLS_mingw32 = "no"
15FILES_${PN}-staticdev_append_mingw32 = " ${libdir}/*.lib" 15FILES_${PN}-staticdev_append_mingw32 = " ${libdir}/*.lib"
16ALLOW_EMPTY_${PN}_mingw32 = "1" 16ALLOW_EMPTY_${PN}_mingw32 = "1"
17 17
18DISTRO_FEATURES_FILTER_NATIVESDK_remove_mingw32 = "debuginfod"
19
18# Do what amounts to a NOOP 20# Do what amounts to a NOOP
19SDK_PACKAGING_FUNC = "do_compile" 21SDK_PACKAGING_FUNC = "do_compile"
20 22
diff --git a/recipes-devtools/gdb/gdb-cross-canadian_%.bbappend b/recipes-devtools/gdb/gdb-cross-canadian_%.bbappend
index c33a9ce..096fc63 100644
--- a/recipes-devtools/gdb/gdb-cross-canadian_%.bbappend
+++ b/recipes-devtools/gdb/gdb-cross-canadian_%.bbappend
@@ -4,3 +4,4 @@ RDEPENDS_${PN}_remove_sdkmingw32 = "nativesdk-python-core nativesdk-python-lang
4EXTRA_OECONF_append_sdkmingw32 = " --without-curses --without-system-readline --with-python=no" 4EXTRA_OECONF_append_sdkmingw32 = " --without-curses --without-system-readline --with-python=no"
5PACKAGECONFIG_remove_sdkmingw32 = "readline" 5PACKAGECONFIG_remove_sdkmingw32 = "readline"
6PACKAGECONFIG_remove_sdkmingw32 = "python" 6PACKAGECONFIG_remove_sdkmingw32 = "python"
7PACKAGECONFIG_remove_sdkmingw32 = "debuginfod"