summaryrefslogtreecommitdiffstats
path: root/meta-linaro/recipes-extra/lng-network-config
diff options
context:
space:
mode:
Diffstat (limited to 'meta-linaro/recipes-extra/lng-network-config')
-rw-r--r--meta-linaro/recipes-extra/lng-network-config/files/70-persistent-net.rules43
-rw-r--r--meta-linaro/recipes-extra/lng-network-config/lng-network-config_0.1.bb11
2 files changed, 54 insertions, 0 deletions
diff --git a/meta-linaro/recipes-extra/lng-network-config/files/70-persistent-net.rules b/meta-linaro/recipes-extra/lng-network-config/files/70-persistent-net.rules
new file mode 100644
index 0000000..5a8be41
--- /dev/null
+++ b/meta-linaro/recipes-extra/lng-network-config/files/70-persistent-net.rules
@@ -0,0 +1,43 @@
1# lng-amarillo-01
2SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="66:06:3e:f9:4f:ae",
3ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
4
5# lng-arndale-01
6SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="02:8e:8f:32:21:98",
7ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
8
9# lng-arndale-02
10SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="02:8c:cc:92:21:98",
11ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
12
13# lng-arndale-03
14SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="02:f4:0c:d6:16:33",
15ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
16
17# lng-arndale-04
18SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="02:8f:4f:09:5e:44",
19ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
20
21# lng-arndale-05
22SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="02:b6:8d:b5:c7:24",
23ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
24
25# lng-generator-01
26SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="d8:9d:67:26:ae:e8",
27ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
28
29# lng-generator-02
30SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="d8:9d:67:26:cd:d8",
31ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
32
33# lng-keystone-01
34SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="c4:ed:ba:99:f4:09",
35ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
36
37# lng-keystone-02
38SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="c4:ed:ba:9a:8c:47",
39ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
40
41# lng-keystone-03
42SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="c4:ed:ba:9a:67:60",
43ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
diff --git a/meta-linaro/recipes-extra/lng-network-config/lng-network-config_0.1.bb b/meta-linaro/recipes-extra/lng-network-config/lng-network-config_0.1.bb
new file mode 100644
index 0000000..2987b04
--- /dev/null
+++ b/meta-linaro/recipes-extra/lng-network-config/lng-network-config_0.1.bb
@@ -0,0 +1,11 @@
1SUMMARY = "This package contains LNG specific configuration"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5RDEPENDS_${PN} = "udev"
6
7SRC_URI = "file://70-persistent-net.rules"
8
9do_install() {
10 install -D -p -m644 ${WORKDIR}/70-persistent-net.rules ${D}/etc/udev/rules.d/70-persistent-net.rules
11}