summaryrefslogtreecommitdiffstats
path: root/meta-linaro-integration/recipes-overlayed/firefox/firefox/debian-hacks/Ignore-system-libjpeg-libpng-and-zlib-version-checki.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-linaro-integration/recipes-overlayed/firefox/firefox/debian-hacks/Ignore-system-libjpeg-libpng-and-zlib-version-checki.patch')
-rw-r--r--meta-linaro-integration/recipes-overlayed/firefox/firefox/debian-hacks/Ignore-system-libjpeg-libpng-and-zlib-version-checki.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-linaro-integration/recipes-overlayed/firefox/firefox/debian-hacks/Ignore-system-libjpeg-libpng-and-zlib-version-checki.patch b/meta-linaro-integration/recipes-overlayed/firefox/firefox/debian-hacks/Ignore-system-libjpeg-libpng-and-zlib-version-checki.patch
new file mode 100644
index 0000000..76368cb
--- /dev/null
+++ b/meta-linaro-integration/recipes-overlayed/firefox/firefox/debian-hacks/Ignore-system-libjpeg-libpng-and-zlib-version-checki.patch
@@ -0,0 +1,42 @@
1From: Mike Hommey <glandium@debian.org>
2Date: Thu, 13 Mar 2008 07:33:42 +0100
3Subject: Ignore system libjpeg, libpng and zlib version checking
4
5Make sure we won't be bitten by upstream changing libjpeg, libpng or zlib
6internal version, which makes system library not used even though
7--with-system-* argument is given to configure.
8---
9 configure.in | 6 +++---
10 1 file changed, 3 insertions(+), 3 deletions(-)
11
12diff --git a/configure.in b/configure.in
13index 18872c4..5c20d46 100644
14--- a/configure.in
15+++ b/configure.in
16@@ -4357,7 +4357,7 @@ else
17 AC_CHECK_LIB(jpeg, jpeg_destroy_compress, [SYSTEM_JPEG=1 JPEG_LIBS="-ljpeg $JPEG_LIBS"], SYSTEM_JPEG=, $JPEG_LIBS)
18 fi
19
20-if test "$SYSTEM_JPEG" = 1; then
21+if test "$SYSTEM_JPEG" = 0; then
22 LIBS="$JPEG_LIBS $LIBS"
23 AC_TRY_COMPILE([ #include <stdio.h>
24 #include <sys/types.h>
25@@ -4397,7 +4397,7 @@ else
26 AC_CHECK_LIB(z, gzread, [SYSTEM_ZLIB=1 ZLIB_LIBS="-lz $ZLIB_LIBS"],
27 [SYSTEM_ZLIB= ZLIB_CFLAGS= ZLIB_LIBS=], $ZLIB_LIBS)
28 fi
29-if test "$SYSTEM_ZLIB" = 1; then
30+if test "$SYSTEM_ZLIB" = 0; then
31 LIBS="$ZLIB_LIBS $LIBS"
32 AC_TRY_COMPILE([ #include <stdio.h>
33 #include <string.h>
34@@ -4473,7 +4473,7 @@ else
35 AC_MSG_ERROR([--with-system-png won't work because the system's libpng doesn't have APNG support]),
36 $_SAVE_PNG_LIBS)
37 fi
38-if test "$SYSTEM_PNG" = 1; then
39+if test "$SYSTEM_PNG" = 0; then
40 LIBS="$PNG_LIBS $LIBS"
41 AC_TRY_COMPILE([ #include <stdio.h>
42 #include <sys/types.h>