summaryrefslogtreecommitdiffstats
path: root/recipes-extended/rxtx/files/sys_io_h_check.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/rxtx/files/sys_io_h_check.patch')
-rw-r--r--recipes-extended/rxtx/files/sys_io_h_check.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-extended/rxtx/files/sys_io_h_check.patch b/recipes-extended/rxtx/files/sys_io_h_check.patch
new file mode 100644
index 0000000..5072f1d
--- /dev/null
+++ b/recipes-extended/rxtx/files/sys_io_h_check.patch
@@ -0,0 +1,35 @@
1Description: sys/io.h does not exist on all systems
2Bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=609152
3Author: Scott Howard <showard@debian.org>
4
5Index: rxtx/configure.in
6===================================================================
7--- rxtx.orig/configure.in 2011-02-23 23:01:09.596613286 -0500
8+++ rxtx/configure.in 2011-02-23 23:02:41.269525630 -0500
9@@ -71,6 +71,7 @@
10 AC_CHECK_HEADERS(sys/time.h)
11 AC_CHECK_HEADERS(sys/signal.h)
12 AC_CHECK_HEADERS(signal.h)
13+AC_CHECK_HEADERS(sys/io.h)
14 AC_CHECK_HEADERS(termios.h)
15 AC_CHECK_HEADERS(grp.h)
16 AC_CHECK_HEADERS(pwd.h)
17Index: rxtx/src/RawImp.c
18===================================================================
19--- rxtx.orig/src/RawImp.c 2011-02-23 23:04:29.641932242 -0500
20+++ rxtx/src/RawImp.c 2011-02-23 23:05:40.487353587 -0500
21@@ -99,11 +99,9 @@
22 # include <linux/serial.h>
23 # include <linux/version.h>
24 #endif
25-#ifndef __APPLE__ /* dima */
26-#ifndef PPC
27-#include <sys/io.h>
28-#endif /* PPC */
29-#endif /* dima */
30+#ifdef HAVE_SYS_IO_H
31+# include <sys/io.h>
32+#endif
33
34 extern int errno;
35 #include "I2CImp.h"