summaryrefslogtreecommitdiffstats
path: root/recipes-extended/rxtx/files/original_debian_changes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/rxtx/files/original_debian_changes.patch')
-rw-r--r--recipes-extended/rxtx/files/original_debian_changes.patch117
1 files changed, 117 insertions, 0 deletions
diff --git a/recipes-extended/rxtx/files/original_debian_changes.patch b/recipes-extended/rxtx/files/original_debian_changes.patch
new file mode 100644
index 0000000..32e9913
--- /dev/null
+++ b/recipes-extended/rxtx/files/original_debian_changes.patch
@@ -0,0 +1,117 @@
1Description: Removes makefile install of RXTXcomm.jar, silences an unnecessary compiling error
2Origin: Mario Joussen <joussen@debian.org>, edited by Scott Howard <showard314@gmail.com> <2010-06-03>
3
4Index: rxtx/src/RS485Imp.c
5===================================================================
6--- rxtx.orig/src/RS485Imp.c 2011-10-31 02:58:18.280985274 -0400
7+++ rxtx/src/RS485Imp.c 2011-10-31 02:58:21.300985346 -0400
8@@ -127,6 +127,7 @@
9 #endif /* !__FreeBSD_kernel__ */
10 #if defined(__linux__)
11 /* Lets let people who upgraded kernels know they may have problems */
12+ /*
13 if (uname (&name) == -1)
14 {
15 fprintf(stderr,"RXTX WARNING: cannot get system name\n");
16@@ -137,6 +138,7 @@
17 fprintf(stderr, "\n\n\nRXTX WARNING: This library was compiled to run with OS release %s and you are currently running OS release %s. In some cases this can be a problem. Try recompiling RXTX if you notice strange behavior. If you just compiled RXTX make sure /usr/include/linux is a symbolic link to the include files that came with the kernel source and not an older copy.\n\n\npress enter to continue\n",UTS_RELEASE,name.release);
18 getchar();
19 }
20+ */
21 #endif /* __linux__ */
22 #endif /* WIN32 */
23 }
24Index: rxtx/src/RawImp.c
25===================================================================
26--- rxtx.orig/src/RawImp.c 2011-10-31 02:58:18.280985274 -0400
27+++ rxtx/src/RawImp.c 2011-10-31 02:58:21.300985346 -0400
28@@ -272,6 +272,7 @@
29 #endif /* !__FreeBSD_kernel__ */
30 #if defined(__linux__)
31 /* Lets let people who upgraded kernels know they may have problems */
32+ /*
33 if (uname (&name) == -1)
34 {
35 fprintf(stderr,"RXTX WARNING: cannot get system name\n");
36@@ -282,6 +283,7 @@
37 fprintf(stderr, "\n\n\nRXTX WARNING: This library was compiled to run with OS release %s and you are currently running OS release %s. In some cases this can be a problem. Try recompiling RXTX if you notice strange behavior. If you just compiled RXTX make sure /usr/include/linux is a symbolic link to the include files that came with the kernel source and not an older copy.\n\n\npress enter to continue\n",UTS_RELEASE,name.release);
38 getchar();
39 }
40+ */
41 #endif /* __linux__ */
42 #endif /* WIN32 */
43 }
44Index: rxtx/src/SerialImp.c
45===================================================================
46--- rxtx.orig/src/SerialImp.c 2011-10-31 02:58:18.284985274 -0400
47+++ rxtx/src/SerialImp.c 2011-10-31 02:58:21.304985346 -0400
48@@ -320,6 +320,7 @@
49 #endif /* DEBUG_TIMING */
50 #if defined(DEBUG) && defined(__linux__)
51 /* Lets let people who upgraded kernels know they may have problems */
52+ /*
53 if (uname (&name) == -1)
54 {
55 report( "RXTX WARNING: cannot get system name\n" );
56@@ -333,6 +334,7 @@
57 report( message );
58 getchar();
59 }
60+ */
61 LEAVE( "RXTXPort:Initialize" );
62 #endif /* DEBUG && __linux__ */
63 }
64Index: rxtx/src/I2CImp.c
65===================================================================
66--- rxtx.orig/src/I2CImp.c 2011-10-31 02:58:18.284985274 -0400
67+++ rxtx/src/I2CImp.c 2011-10-31 02:58:21.304985346 -0400
68@@ -127,6 +127,7 @@
69 #endif /* !__FreeBSD_kernel__ */
70 #if defined(__linux__)
71 /* Lets let people who upgraded kernels know they may have problems */
72+ /*
73 if (uname (&name) == -1)
74 {
75 fprintf(stderr,"RXTX WARNING: cannot get system name\n");
76@@ -137,6 +138,7 @@
77 fprintf(stderr, "\n\n\nRXTX WARNING: This library was compiled to run with OS release %s and you are currently running OS release %s. In some cases this can be a problem. Try recompiling RXTX if you notice strange behavior. If you just compiled RXTX make sure /usr/include/linux is a symbolic link to the include files that came with the kernel source and not an older copy.\n\n\npress enter to continue\n",UTS_RELEASE,name.release);
78 getchar();
79 }
80+ */
81 #endif /* __linux__ */
82 #endif /* WIN32 */
83 }
84Index: rxtx/src/SerialImp.cpp
85===================================================================
86--- rxtx.orig/src/SerialImp.cpp 2011-10-31 02:58:18.284985274 -0400
87+++ rxtx/src/SerialImp.cpp 2011-10-31 02:58:21.304985346 -0400
88@@ -142,6 +142,7 @@
89 #endif /* !__FreeBSD_kernel__ */
90 #ifdef DEBUG
91 /* Lets let people who upgraded kernels know they may have problems */
92+ /*
93 if (uname (&name) == -1)
94 {
95 report("RXTX WARNING: cannot get system name\n");
96@@ -153,6 +154,7 @@
97 name.release);
98 getchar();
99 }
100+ */
101 #endif /* DEBUG */
102 #endif /* __BEOS__ */
103 #endif /* WIN32 */
104Index: rxtx/Makefile.am
105===================================================================
106--- rxtx.orig/Makefile.am 2011-10-31 02:55:54.600981860 -0400
107+++ rxtx/Makefile.am 2011-10-31 02:58:21.304985346 -0400
108@@ -137,7 +137,8 @@
109
110 # create the javadoc files.
111 docs: $(CLASSES)
112- $(JAVADOC) $(javafiles)
113+ mkdir api
114+ cd api && $(JAVADOC) $(javafiles)
115
116 ################ WIN32 CrossCompiling from here down #######################
117