summaryrefslogtreecommitdiffstats
path: root/recipes-core/xml-commons/xpp2_2.1.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/xml-commons/xpp2_2.1.10.bb')
-rw-r--r--recipes-core/xml-commons/xpp2_2.1.10.bb22
1 files changed, 11 insertions, 11 deletions
diff --git a/recipes-core/xml-commons/xpp2_2.1.10.bb b/recipes-core/xml-commons/xpp2_2.1.10.bb
index 2239173..54d69f4 100644
--- a/recipes-core/xml-commons/xpp2_2.1.10.bb
+++ b/recipes-core/xml-commons/xpp2_2.1.10.bb
@@ -12,22 +12,22 @@ inherit java-library
12DEPENDS = "fastjar-native virtual/javac-native" 12DEPENDS = "fastjar-native virtual/javac-native"
13 13
14do_compile() { 14do_compile() {
15 if [ -d build-oe ]; then 15 if [ -d build-oe ]; then
16 rm -rf build-oe 16 rm -rf build-oe
17 fi 17 fi
18 mkdir -p build-oe 18 mkdir -p build-oe
19 19
20 sourcepath="src/java/drivers/jaxp11:src/java/drivers/sax2:src/java/impl/factory:src/java/impl/format:src/java/impl/node:src/java/impl/pullparser:src/java/impl/tag:src/java/intf" 20 sourcepath="src/java/drivers/jaxp11:src/java/drivers/sax2:src/java/impl/factory:src/java/impl/format:src/java/impl/node:src/java/impl/pullparser:src/java/impl/tag:src/java/intf"
21 21
22 findpath="${sourcepath//:/ }" 22 findpath="${sourcepath//:/ }"
23 23
24 javac -sourcepath $sourcepath -d build-oe `find $findpath -name "*.java"` 24 javac -sourcepath $sourcepath -d build-oe `find $findpath -name "*.java"`
25 25
26 mkdir -p build-oe/META-INF/services 26 mkdir -p build-oe/META-INF/services
27 cp src/java/drivers/jaxp11/META-INF/services/javax.xml.parsers.SAXParserFactory build-oe/META-INF/services 27 cp src/java/drivers/jaxp11/META-INF/services/javax.xml.parsers.SAXParserFactory build-oe/META-INF/services
28 cp src/java/impl/factory/META-INF/services/org.gjt.xpp.XmlPullParserFactory build-oe/META-INF/services 28 cp src/java/impl/factory/META-INF/services/org.gjt.xpp.XmlPullParserFactory build-oe/META-INF/services
29 29
30 fastjar -C build-oe -c -f ${JARFILENAME} . 30 fastjar -C build-oe -c -f ${JARFILENAME} .
31} 31}
32 32
33SRC_URI[md5sum] = "865ca4e2496c215d301b57450137626f" 33SRC_URI[md5sum] = "865ca4e2496c215d301b57450137626f"