summaryrefslogtreecommitdiffstats
path: root/recipes-core/xml-commons/xpp2_2.1.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/xml-commons/xpp2_2.1.10.bb')
-rw-r--r--recipes-core/xml-commons/xpp2_2.1.10.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-core/xml-commons/xpp2_2.1.10.bb b/recipes-core/xml-commons/xpp2_2.1.10.bb
new file mode 100644
index 0000000..2239173
--- /dev/null
+++ b/recipes-core/xml-commons/xpp2_2.1.10.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "Streaming pull XML parser for java"
2LICENSE = "BSD-like"
3
4HOMEPAGE = "http://www.extreme.indiana.edu/xgws/xsoap/xpp/"
5
6SRC_URI = "http://www.extreme.indiana.edu/xgws/xsoap/xpp/download/PullParser2/PullParser2.1.10.tgz"
7
8S = "${WORKDIR}/PullParser${PV}"
9
10inherit java-library
11
12DEPENDS = "fastjar-native virtual/javac-native"
13
14do_compile() {
15 if [ -d build-oe ]; then
16 rm -rf build-oe
17 fi
18 mkdir -p build-oe
19
20 sourcepath="src/java/drivers/jaxp11:src/java/drivers/sax2:src/java/impl/factory:src/java/impl/format:src/java/impl/node:src/java/impl/pullparser:src/java/impl/tag:src/java/intf"
21
22 findpath="${sourcepath//:/ }"
23
24 javac -sourcepath $sourcepath -d build-oe `find $findpath -name "*.java"`
25
26 mkdir -p build-oe/META-INF/services
27 cp src/java/drivers/jaxp11/META-INF/services/javax.xml.parsers.SAXParserFactory build-oe/META-INF/services
28 cp src/java/impl/factory/META-INF/services/org.gjt.xpp.XmlPullParserFactory build-oe/META-INF/services
29
30 fastjar -C build-oe -c -f ${JARFILENAME} .
31}
32
33SRC_URI[md5sum] = "865ca4e2496c215d301b57450137626f"
34SRC_URI[sha256sum] = "ad82569b809e29c19b8223feaa12923f97bb4bbc942ff985857f9d853db489cf"