summaryrefslogtreecommitdiffstats
path: root/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb')
-rw-r--r--recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb b/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb
new file mode 100644
index 0000000..794ab4b
--- /dev/null
+++ b/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb
@@ -0,0 +1,42 @@
1DESCRIPTION = "Library to resolve various public or system identifiers into accessible URLs (Java)"
2AUTHOR = "Apache Software Foundation"
3LICENSE = "AL2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.resolver.txt;md5=d229da563da18fe5d58cd95a6467d584"
5
6SRC_URI = "http://archive.apache.org/dist/xml/commons/xml-commons-resolver-${PV}.tar.gz"
7
8inherit java-library
9
10S = "${WORKDIR}/xml-commons-resolver-${PV}"
11
12DEPENDS = "fastjar-native jaxp1.3"
13DEPENDS_virtclass-native = "fastjar-native jaxp1.3-native"
14
15do_unpackpost() {
16 find src -exec \
17 sed -i -e "s|@impl.name@|XmlResolver|" \
18 -e "s|@impl.version@|1.2|" {} \;
19}
20
21addtask unpackpost after do_unpack before do_patch
22
23JARFILENAME = "resolver.jar"
24ALTJARFILENAMES = ""
25
26do_compile() {
27 mkdir -p build
28
29 cp=${STAGING_DATADIR_JAVA}/jaxp1.3.jar
30
31 javac -sourcepath src -d build -classpath $cp `find src -name "*.java" -and -not -wholename "*tests*"`
32
33 (cd src && find org -name "*.xml" -o -name "*.txt" -o -name "*.src" -exec cp {} ../build/{} \;)
34
35 fastjar -C build -c -m src/manifest.resolver -f ${JARFILENAME} org
36}
37
38SRC_URI[md5sum] = "46d52acdb67ba60f0156043f30108766"
39SRC_URI[sha256sum] = "55dbe7bd56452c175320ce9a97b752252c5537427221323c72e9b9c1ac221efe"
40
41NATIVE_INSTALL_WORKS = "1"
42BBCLASSEXTEND = "native"