summaryrefslogtreecommitdiffstats
path: root/recipes-core/xml-commons/jdom_1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/xml-commons/jdom_1.1.bb')
-rw-r--r--recipes-core/xml-commons/jdom_1.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-core/xml-commons/jdom_1.1.bb b/recipes-core/xml-commons/jdom_1.1.bb
new file mode 100644
index 0000000..1a77f05
--- /dev/null
+++ b/recipes-core/xml-commons/jdom_1.1.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Parses, manipulates, and outputs XML using standard Java constructs"
2LICENSE = "BSD"
3
4HOMEPAGE = "http://jdom.org/
5
6DEPENDS = "fastjar-native jaxen"
7
8SRC_URI = "\
9 http://www.jdom.org/dist/binary/archive/jdom-${PV}.tar.gz \
10 "
11
12inherit java-library
13
14do_compile() {
15 mkdir -p build
16
17 oe_makeclasspath cp -s jaxen
18
19 javac -sourcepath src/java -cp $cp -d build `find src/java -name "*.java"`
20
21 fastjar -C build -c -f ${JARFILENAME} .
22}
23
24
25SRC_URI[md5sum] = "22745cbaaddb12884ed8ee09083d8fe2"
26SRC_URI[sha256sum] = "a13549087141be24ad176b659afdc2c675f1ffa5288ff999a193d6d44a282056"