summaryrefslogtreecommitdiffstats
path: root/recipes-core/xml-commons/jaxen_1.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/xml-commons/jaxen_1.1.1.bb')
-rw-r--r--recipes-core/xml-commons/jaxen_1.1.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-core/xml-commons/jaxen_1.1.1.bb b/recipes-core/xml-commons/jaxen_1.1.1.bb
new file mode 100644
index 0000000..7180dda
--- /dev/null
+++ b/recipes-core/xml-commons/jaxen_1.1.1.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "XPath library written in Java"
2LICENSE = "BSD"
3
4HOMEPAGE = "http://jaxen.codehaus.org/
5
6DEPENDS = "fastjar-native xerces-j xom"
7
8SRC_URI = "\
9 http://dist.codehaus.org/jaxen/distributions/jaxen-${PV}-src.tar.gz;name=archive \
10 http://www.jdom.org/dist/binary/archive/jdom-1.1.tar.gz;name=jdom \
11 "
12
13inherit java-library
14
15do_compile() {
16 mkdir -p build
17
18 oe_makeclasspath cp -s xercesImpl xom
19 scp="src/java/main:${WORKDIR}/jdom-1.1/src/java"
20
21 javac -sourcepath $scp -cp $cp -d build `find src/java/main -name "*.java" -and -not -wholename "*dom4j*"`
22 (cd src && find org -name "*.properties" -exec cp {} ../build/{} \;)
23
24 rm -rf build/org/jdom
25
26 fastjar -C build -c -f ${JARFILENAME} .
27}
28
29
30SRC_URI[archive.md5sum] = "b598ae6b7e765a92e13667b0a80392f4"
31SRC_URI[archive.sha256sum] = "f24ae604a20da87e3716bb1d441c483e56479eaef4e99888f41be06059790bca"
32SRC_URI[jdom.md5sum] = "22745cbaaddb12884ed8ee09083d8fe2"
33SRC_URI[jdom.sha256sum] = "a13549087141be24ad176b659afdc2c675f1ffa5288ff999a193d6d44a282056"