summaryrefslogtreecommitdiffstats
path: root/recipes-core/servlet-api/servlet2.4_5.5.26.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/servlet-api/servlet2.4_5.5.26.bb')
-rw-r--r--recipes-core/servlet-api/servlet2.4_5.5.26.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-core/servlet-api/servlet2.4_5.5.26.bb b/recipes-core/servlet-api/servlet2.4_5.5.26.bb
new file mode 100644
index 0000000..ee80e5e
--- /dev/null
+++ b/recipes-core/servlet-api/servlet2.4_5.5.26.bb
@@ -0,0 +1,41 @@
1DESCRIPTION = "Servlet API 2.4 (from Tomcat 5.5)"
2LICENSE = "AL2.0"
3AUTHOR = "Apache Software Foundation"
4
5SRC_URI = "http://archive.apache.org/dist/tomcat/tomcat-5/v${PV}/src/apache-tomcat-${PV}-src.tar.gz"
6
7S = "${WORKDIR}/apache-tomcat-${PV}-src/servletapi/jsr154"
8
9inherit java-library
10
11DEPENDS = "fastjar-native"
12
13# Value of implementation.revision in build.xml
14IMPL_REVISION = "1"
15
16JARFILENAME = "servlet-api-2.4.${IMPL_REVISION}.jar"
17ALTJARFILENAMES = "servlet-api-2.4.jar servlet-api.jar servlet2.4.jar"
18
19do_unpackpost() {
20 sed -i -e "s|2.3.@implementation.version@|2.4.${IMPL_REVISION}|" src/etc/manifest
21}
22
23addtask unpackpost after do_unpack before do_patch
24
25do_compile() {
26 mkdir -p build
27
28 javac -sourcepath src/share -d build `find src/share/javax -name \*.java`
29
30 # Copy extraneous files according to build.xml's compile task
31 (cd src/share && find . -name "*.properties" -exec cp {} ../../build/{} \;)
32
33 mkdir -p build/javax/servlet/resources
34 cp src/share/dtd/jsp*.dtd build/javax/servlet/resources
35 cp src/share/dtd/web-jsp*.dtd build/javax/servlet/resources
36
37 fastjar -C build -c -m src/etc/manifest -f ${JARFILENAME} .
38}
39
40SRC_URI[md5sum] = "642b6526354cb18c5b5d77ebef8109ae"
41SRC_URI[sha256sum] = "ddc677d7391c438e6102d0b3e9653eaca661344ef74b0260c1f488340d660395"