summaryrefslogtreecommitdiffstats
path: root/recipes-core/rhino/rhino_1.7r2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/rhino/rhino_1.7r2.bb')
-rw-r--r--recipes-core/rhino/rhino_1.7r2.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-core/rhino/rhino_1.7r2.bb b/recipes-core/rhino/rhino_1.7r2.bb
new file mode 100644
index 0000000..3a3f553
--- /dev/null
+++ b/recipes-core/rhino/rhino_1.7r2.bb
@@ -0,0 +1,46 @@
1DESCRIPTION = "Lexical analyzer generator for Java"
2LICENSE = "GPL MPL"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b8ba559ba419681dbf8280b6721df0af"
4
5BBCLASSEXTEND = "native"
6
7inherit java-library
8
9SRC_URI = "\
10 ftp://ftp.mozilla.org/pub/mozilla.org/js/rhino1_7R2.zip \
11 file://rhino \
12 file://rhino-jsc \
13 "
14
15S = "${WORKDIR}/rhino1_7R2"
16
17PACKAGES = "${JPN} rhino"
18
19FILES_${PN} = "${bindir}/rhino ${bindir}/rhino-jsc"
20RDEPENDS_${PN} = "java2-runtime ${JPN}"
21RDEPENDS_${PN}_virtclass-native = ""
22
23do_compile() {
24 mkdir -p build
25
26 # Compatibility fix for jamvm which has non-genericised
27 # java.lang classes. :(
28 bcp_arg="-bootclasspath ${STAGING_DATADIR_NATIVE}/classpath/glibj.zip"
29
30 javac $bcp_arg -source 1.5 -sourcepath src -d build `find src -name "*.java"`
31
32 mkdir -p build/org/mozilla/javascript/resources
33 cp src/org/mozilla/javascript/resources/*.properties build/org/mozilla/javascript/resources
34
35 fastjar -m ${S}/src/manifest -C build -c -f ${JARFILENAME} .
36}
37
38do_install_append() {
39 install -d ${D}${bindir}
40
41 install -m 0755 ${WORKDIR}/rhino ${D}${bindir}
42 install -m 0755 ${WORKDIR}/rhino-jsc ${D}${bindir}
43}
44
45SRC_URI[md5sum] = "40d0a9abec8169e42920214b37fa8e0e"
46SRC_URI[sha256sum] = "677f7dc1b67a1587bc03974d5f0720474a56b8f29835e1d860739908df8462dc"