summaryrefslogtreecommitdiffstats
path: root/recipes-core/openjdk/patches-openjdk-8/0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/openjdk/patches-openjdk-8/0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch')
-rw-r--r--recipes-core/openjdk/patches-openjdk-8/0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch43
1 files changed, 0 insertions, 43 deletions
diff --git a/recipes-core/openjdk/patches-openjdk-8/0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch b/recipes-core/openjdk/patches-openjdk-8/0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch
deleted file mode 100644
index f9feca0..0000000
--- a/recipes-core/openjdk/patches-openjdk-8/0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From 90220d41f65910b108c901977eefe78fc1edecc5 Mon Sep 17 00:00:00 2001
2From: Nicola Lunghi <nicola.lunghi@jci.com>
3Date: Mon, 17 Jun 2019 13:59:26 +0100
4Subject: [PATCH] Enable HotSpot builds on 5.x Linux kernels
5
68217753: Enable HotSpot builds on 5.x Linux kernels
7Summary: Remove Linux kernel version check as very unlikely a kernel older than 2.4 will be used.
8Reviewed-by: erikj
9
10Upstream-Status: Backport (http://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/5af8ec63c21c)
11---
12 hotspot/make/linux/Makefile | 15 +--------------
13 1 file changed, 1 insertion(+), 14 deletions(-)
14
15diff --git a/hotspot/make/linux/Makefile b/hotspot/make/linux/Makefile
16index 17c14097..e8f20104 100644
17--- a/hotspot/make/linux/Makefile
18+++ b/hotspot/make/linux/Makefile
19@@ -227,20 +227,7 @@ all:
20 @echo " $(TARGETS_SHARK)"
21 @echo " $(TARGETS_MINIMAL1)"
22
23-checks: check_os_version check_j2se_version
24-
25-# We do not want people accidentally building on old systems (e.g. Linux 2.2.x,
26-# Solaris 2.5.1, 2.6).
27-# Disable this check by setting DISABLE_HOTSPOT_OS_VERSION_CHECK=ok.
28-
29-SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 3% 4%
30-OS_VERSION := $(shell uname -r)
31-EMPTY_IF_NOT_SUPPORTED = $(filter $(SUPPORTED_OS_VERSION),$(OS_VERSION))
32-
33-check_os_version:
34-ifeq ($(DISABLE_HOTSPOT_OS_VERSION_CHECK)$(EMPTY_IF_NOT_SUPPORTED),)
35- $(QUIETLY) >&2 echo "*** This OS is not supported:" `uname -a`; exit 1;
36-endif
37+checks: check_j2se_version
38
39 # jvmti.make requires XSLT (J2SE 1.4.x or newer):
40 XSLT_CHECK = $(REMOTE) $(RUN.JAVAP) javax.xml.transform.TransformerFactory
41--
422.20.1
43