summaryrefslogtreecommitdiffstats
path: root/recipes-core/openjdk/openjdk-6/build-hacks.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/openjdk/openjdk-6/build-hacks.patch')
-rw-r--r--recipes-core/openjdk/openjdk-6/build-hacks.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-core/openjdk/openjdk-6/build-hacks.patch b/recipes-core/openjdk/openjdk-6/build-hacks.patch
new file mode 100644
index 0000000..02a8300
--- /dev/null
+++ b/recipes-core/openjdk/openjdk-6/build-hacks.patch
@@ -0,0 +1,31 @@
1Index: icedtea6-1.8/Makefile.am
2===================================================================
3--- icedtea6-1.8.orig/Makefile.am 2010-04-12 23:55:51.754838172 +0200
4+++ icedtea6-1.8/Makefile.am 2010-06-16 15:17:10.224708601 +0200
5@@ -477,6 +477,11 @@
6 JAVAC="" \
7 JAVA_HOME="" \
8 JDK_HOME="" \
9+ OE_CFLAGS="$(OE_CFLAGS)" \
10+ OE_CPPFLAGS="$(OE_CPPFLAGS)" \
11+ OE_CXXFLAGS="$(OE_CXXFLAGS)" \
12+ OE_LDFLAGS="$(OE_LDFLAGS)" \
13+ OE_LAUNCHER_LDFLAGS="$(OE_LAUNCHER_LDFLAGS)" \
14 DISTRIBUTION_ID="$(DIST_ID)" \
15 DERIVATIVE_ID="$(ICEDTEA_NAME) $(PACKAGE_VERSION)$(ICEDTEA_REV)" \
16 DEBUG_CLASSFILES="true" \
17Index: icedtea6-1.8/javac.in
18===================================================================
19--- icedtea6-1.8.orig/javac.in 2010-03-25 15:10:41.714835519 +0100
20+++ icedtea6-1.8/javac.in 2010-06-16 15:14:31.205334756 +0200
21@@ -35,7 +35,9 @@
22 elif [ ! -z "@ECJ@" ] ; then
23 @ECJ@ -1.5 -nowarn $bcoption $NEW_ARGS
24 else
25+ # Compiling hotspot-tools consumes tons of memory and exceeds any default
26+ # limits for jamvm and cacao.
27 CLASSPATH=@ECJ_JAR@${CLASSPATH:+:}$CLASSPATH \
28- @JAVA@ org.eclipse.jdt.internal.compiler.batch.Main -1.5 -nowarn $bcoption $NEW_ARGS
29+ @JAVA@ -Xmx1024m org.eclipse.jdt.internal.compiler.batch.Main -1.5 -nowarn $bcoption $NEW_ARGS
30 fi
31