summaryrefslogtreecommitdiffstats
path: root/recipes-core/llvm/llvm-common.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/llvm/llvm-common.bb')
-rw-r--r--recipes-core/llvm/llvm-common.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-core/llvm/llvm-common.bb b/recipes-core/llvm/llvm-common.bb
new file mode 100644
index 0000000..38ca1ee
--- /dev/null
+++ b/recipes-core/llvm/llvm-common.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "Helper script for OE's llvm support"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420 \
5 "
6
7SRC_URI = "file://llvm-config"
8
9do_install() {
10 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
11 install -m 0755 ${WORKDIR}/llvm-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/
12}
13
14do_install_virtclass-native() {
15 install -d ${D}${bindir}
16 install -m 0755 ${WORKDIR}/llvm-config ${D}${bindir}
17}
18
19BBCLASSEXTEND = "native"