summaryrefslogtreecommitdiffstats
path: root/recipes-core/junit/junit_3.8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/junit/junit_3.8.2.bb')
-rw-r--r--recipes-core/junit/junit_3.8.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-core/junit/junit_3.8.2.bb b/recipes-core/junit/junit_3.8.2.bb
new file mode 100644
index 0000000..a628ac4
--- /dev/null
+++ b/recipes-core/junit/junit_3.8.2.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "JUnit is a testing framework for Java"
2AUTHOR = "junit.org"
3HOMEPAGE = "http://www.junit.org"
4LICENSE = "CPL"
5LIC_FILES_CHKSUM = "file://cpl-v10.html;md5=67a4b75d42edcbd82d2878eba913691b"
6
7SRC_URI = "http://downloads.sourceforge.net/junit/junit${PV}.zip"
8
9S = "${WORKDIR}/junit${PV}"
10
11inherit java-library
12
13do_unpackpost() {
14 mkdir -p src
15
16 # Prevent deletion by do_removebinaries.
17 mv src.jar src.zip
18
19 unzip src.zip -d src
20}
21
22addtask unpackpost before do_removebinaries after do_unpack
23
24do_compile() {
25 mkdir -p build
26
27 # Workaround for jamvm.
28 bcp=${STAGING_DATADIR_NATIVE}/classpath/glibj.zip
29
30 javac -bootclasspath $bcp -sourcepath src -d build `find src -name "*.java"`
31
32 fastjar -C build -c -f ${JARFILENAME} .
33}
34
35SRC_URI[md5sum] = "9b8963ba2147a64bd5f1574b6fd289cb"
36SRC_URI[sha256sum] = "aae23d20e6f4dc45b4bf0b10fedcbd209c100342a0cafce1aa07d2da6da1f24a"
37
38NATIVE_INSTALL_WORKS = "1"
39BBCLASSEXTEND = "native"