summaryrefslogtreecommitdiffstats
path: root/recipes-core/jamvm/jamvm-initial/jamvm-initial.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/jamvm/jamvm-initial/jamvm-initial.patch')
-rw-r--r--recipes-core/jamvm/jamvm-initial/jamvm-initial.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/recipes-core/jamvm/jamvm-initial/jamvm-initial.patch b/recipes-core/jamvm/jamvm-initial/jamvm-initial.patch
new file mode 100644
index 0000000..fb069f8
--- /dev/null
+++ b/recipes-core/jamvm/jamvm-initial/jamvm-initial.patch
@@ -0,0 +1,63 @@
1Index: jamvm-1.4.5/configure.ac
2===================================================================
3--- jamvm-1.4.5.orig/configure.ac
4+++ jamvm-1.4.5/configure.ac
5@@ -1,6 +1,6 @@
6 dnl Process this file with autoconf to produce a configure script.
7 AC_INIT(src/jam.c)
8-AM_INIT_AUTOMAKE(jamvm, 1.4.5)
9+AM_INIT_AUTOMAKE(jamvm-initial, 1.4.5)
10 AC_CONFIG_HEADERS([src/config.h])
11 AC_PREFIX_DEFAULT(/usr/local/jamvm)
12
13Index: jamvm-1.4.5/lib/Makefile.am
14===================================================================
15--- jamvm-1.4.5.orig/lib/Makefile.am
16+++ jamvm-1.4.5/lib/Makefile.am
17@@ -1,4 +1,4 @@
18-@use_zip_yes@ GLIBJ_ZIP = ${with_classpath_install_dir}/share/classpath/glibj.zip
19+@use_zip_yes@ GLIBJ_ZIP = ${with_classpath_install_dir}/share/classpath-initial/glibj.zip
20 @use_zip_no@ GLIBJ_ZIP = ${with_classpath_install_dir}/share/classpath/
21
22 SUBDIRS = jamvm java gnu sun
23Index: jamvm-1.4.5/src/dll.c
24===================================================================
25--- jamvm-1.4.5.orig/src/dll.c
26+++ jamvm-1.4.5/src/dll.c
27@@ -294,7 +294,7 @@ char *getDllPath() {
28 }
29
30 char *getBootDllPath() {
31- return CLASSPATH_INSTALL_DIR"/lib/classpath";
32+ return CLASSPATH_INSTALL_DIR"/lib/classpath-initial";
33 }
34
35 char *getDllName(char *name) {
36Index: jamvm-1.4.5/src/Makefile.am
37===================================================================
38--- jamvm-1.4.5.orig/src/Makefile.am
39+++ jamvm-1.4.5/src/Makefile.am
40@@ -2,7 +2,7 @@ SUBDIRS = os
41 DIST_SUBDIRS = os arch
42
43 bin_PROGRAMS = jamvm
44-include_HEADERS = jni.h
45+noinst_HEADERS = jni.h
46
47 lib_LTLIBRARIES = libjvm.la
48 noinst_LTLIBRARIES = libcore.la
49Index: jamvm-1.4.5/src/class.c
50===================================================================
51--- jamvm-1.4.5.orig/src/class.c
52+++ jamvm-1.4.5/src/class.c
53@@ -1653,8 +1653,8 @@ void scanDirsForJars(char *directories)
54 }
55
56 #ifdef USE_ZIP
57-#define JAMVM_CLASSES INSTALL_DIR"/share/jamvm/classes.zip"
58-#define CLASSPATH_CLASSES CLASSPATH_INSTALL_DIR"/share/classpath/glibj.zip"
59+#define JAMVM_CLASSES INSTALL_DIR"/share/jamvm-initial/classes.zip"
60+#define CLASSPATH_CLASSES CLASSPATH_INSTALL_DIR"/share/classpath-initial/glibj.zip"
61 #else
62 #define JAMVM_CLASSES INSTALL_DIR"/share/jamvm/classes"
63 #define CLASSPATH_CLASSES CLASSPATH_INSTALL_DIR"/share/classpath"