summaryrefslogtreecommitdiffstats
path: root/recipes-core/jakarta-libs/poi_3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/jakarta-libs/poi_3.0.bb')
-rw-r--r--recipes-core/jakarta-libs/poi_3.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-core/jakarta-libs/poi_3.0.bb b/recipes-core/jakarta-libs/poi_3.0.bb
new file mode 100644
index 0000000..b207bec
--- /dev/null
+++ b/recipes-core/jakarta-libs/poi_3.0.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Java library for manipulating various file formats based upon Microsoft's OLE 2 Compound Document"
2LICENSE = "AL2.0"
3AUTHOR = "Apache Software Foundation"
4
5SRC_URI = "http://www.apache.org/dist/jakarta/poi/release/src/${BPN}-src-${PV}-FINAL-20070503.tar.gz"
6
7S = "${WORKDIR}/${BPN}-3.0-rc4"
8
9inherit java-library
10
11DEPENDS = "fastjar-native commons-collections3 commons-logging commons-lang commons-beanutils log4j1.2 xalan-j"
12
13do_compile() {
14 mkdir -p build
15
16 oe_makeclasspath cp -s commons-collections3 commons-logging commons-lang commons-beanutils log4j-1.2 xalan2
17
18 javac -sourcepath src/java -cp $cp -d build \
19 `find src/java -name \*.java`
20
21 (cd src/java && find . -name "*.properties" -exec cp {} ../../build/{} \;)
22
23 fastjar -C build -c -f ${JARFILENAME} .
24}
25
26SRC_URI[md5sum] = "1fb488c4061256197a667f1c480ffc33"
27SRC_URI[sha256sum] = "48a5aabb873d4cc654c95acf6576868d7a8a3ee97e1c6418e1d716698b6efa76"