summaryrefslogtreecommitdiffstats
path: root/recipes-core/jakarta-libs/logkit_1.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/jakarta-libs/logkit_1.2.2.bb')
-rw-r--r--recipes-core/jakarta-libs/logkit_1.2.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-core/jakarta-libs/logkit_1.2.2.bb b/recipes-core/jakarta-libs/logkit_1.2.2.bb
new file mode 100644
index 0000000..f23b037
--- /dev/null
+++ b/recipes-core/jakarta-libs/logkit_1.2.2.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "Logging toolkit designed for secure performance orientated logging in Java applications"
2AUTHOR = "Apache Software Foundation"
3LICENSE = "AL2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f1a1c8e1996e51c4dbc73e592a2ecf05"
5
6SRC_URI = "http://www.apache.org/dist/avalon/logkit/source/${BP}-src.tar.gz"
7
8inherit java-library
9
10S = "${WORKDIR}/${BP}-dev"
11
12DEPENDS = "oro servlet2.3 gnumail gnujaf log4j1.2 avalon-framework-api"
13DEPENDS_virtclass-native = "oro-native servlet2.3-native gnumail-native gnujaf-native log4j1.2-native avalon-framework-api-native"
14
15do_compile() {
16 mkdir -p build
17
18 oe_makeclasspath cp -s oro servlet-2.3 activation gnumail log4j-1.2 avalon-framework-api
19
20 # Built everything but the JMS and JMX classes (like in Debian)
21 javac -encoding ISO8859-1 -sourcepath src/java -cp $cp -d build \
22 `find src/java -name \*.java -and -not \( -iwholename "*jms*" -or -wholename "*test*" \)`
23
24 (cd src/java && find . -name "*.properties" -exec cp {} ../../build/{} \;)
25
26 fastjar -C build -c -f ${JARFILENAME} .
27}
28
29SRC_URI[md5sum] = "996ee20d6b5785ab71f4692f64d10f9c"
30SRC_URI[sha256sum] = "2c81edc87571fbd05797da7f65515e089c62cbb735bdbd10f93e29bd3aa3ddb8"
31
32NATIVE_INSTALL_WORKS = "1"
33BBCLASSEXTEND = "native"