summaryrefslogtreecommitdiffstats
path: root/recipes-core/jakarta-libs/log4j1.2_1.2.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/jakarta-libs/log4j1.2_1.2.15.bb')
-rw-r--r--recipes-core/jakarta-libs/log4j1.2_1.2.15.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-core/jakarta-libs/log4j1.2_1.2.15.bb b/recipes-core/jakarta-libs/log4j1.2_1.2.15.bb
new file mode 100644
index 0000000..ab62176
--- /dev/null
+++ b/recipes-core/jakarta-libs/log4j1.2_1.2.15.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "Java library to help the programmer output log statements to a variety of output targets"
2AUTHOR = "Apache Software Foundation"
3LICENSE = "AL2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=f4ce41a6d1028498fcacde12f589bce7"
5
6SRC_URI = "http://archive.apache.org/dist/logging/log4j/${PV}/apache-log4j-${PV}.tar.gz"
7
8inherit java-library
9
10S = "${WORKDIR}/apache-log4j-${PV}"
11
12DEPENDS = "gnumail gnujaf"
13DEPENDS_virtclass-native = "gnumail-native gnujaf-native"
14
15
16JARFILENAME = "log4j-${PV}.jar"
17ALTJARFILENAMES = "log4j-1.2.jar log4j1.2.jar"
18
19do_compile() {
20 mkdir -p build
21
22 oe_makeclasspath cp -s activation gnumail
23
24 # Built everything but the JMS and JMX classes (like in Debian)
25 javac -sourcepath src/main/java -cp $cp -d build `find src/main/java -name "*.java" -and -not \( -iwholename "*jms*" -or -iwholename "*jmx*" \)`
26
27 cp -R src/main/resources/* build/
28
29 fastjar -C build -c -f ${JARFILENAME} .
30}
31
32SRC_URI[md5sum] = "10f04abe4d68d5a89e8eb167e4e45e1a"
33SRC_URI[sha256sum] = "f5d9f6aa78b9156ae2de2a32d0f26507d2e73db4993d501db2e79f0bd803ab31"
34
35NATIVE_INSTALL_WORKS = "1"
36BBCLASSEXTEND = "native"
37