summaryrefslogtreecommitdiffstats
path: root/recipes-core/icedtea/icedtea6-native-1.8/disable-library-checks.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/icedtea/icedtea6-native-1.8/disable-library-checks.patch')
-rw-r--r--recipes-core/icedtea/icedtea6-native-1.8/disable-library-checks.patch141
1 files changed, 141 insertions, 0 deletions
diff --git a/recipes-core/icedtea/icedtea6-native-1.8/disable-library-checks.patch b/recipes-core/icedtea/icedtea6-native-1.8/disable-library-checks.patch
new file mode 100644
index 0000000..23b8bed
--- /dev/null
+++ b/recipes-core/icedtea/icedtea6-native-1.8/disable-library-checks.patch
@@ -0,0 +1,141 @@
1Index: icedtea6-1.7/configure.ac
2===================================================================
3--- icedtea6-1.7.orig/configure.ac 2010-01-26 04:52:18.000000000 +0100
4+++ icedtea6-1.7/configure.ac 2010-02-08 12:05:51.354556052 +0100
5@@ -205,9 +205,9 @@
6 fi
7
8 dnl pkgconfig cannot be used to find these headers and libraries.
9-AC_CHECK_HEADERS([cups/cups.h cups/ppd.h],[]
10- ,[AC_MSG_ERROR("CUPS headers were not found -
11- try installing cups-devel.")])
12+#AC_CHECK_HEADERS([cups/cups.h cups/ppd.h],[]
13+# ,[AC_MSG_ERROR("CUPS headers were not found -
14+# try installing cups-devel.")])
15 AC_CHECK_HEADERS([X11/X.h],[]
16 ,[AC_MSG_ERROR("xorg headers were not found -
17 try installing xorg-x11-proto-devel.")])
18@@ -239,12 +239,12 @@
19 AC_SUBST(XT_LIBS)
20
21 dnl Check for libXp headers and libraries.
22-PKG_CHECK_MODULES(XP, xp,[XP_FOUND=yes],[XP_FOUND=no])
23-if test "x${XP_FOUND}" = xno
24-then
25- AC_MSG_ERROR([Could not find Xp - \
26- Try installing libXp-devel.])
27-fi
28+#PKG_CHECK_MODULES(XP, xp,[XP_FOUND=yes],[XP_FOUND=no])
29+#if test "x${XP_FOUND}" = xno
30+#then
31+# AC_MSG_ERROR([Could not find Xp - \
32+# Try installing libXp-devel.])
33+#fi
34 AC_SUBST(XP_CFLAGS)
35 AC_SUBST(XP_LIBS)
36
37@@ -258,16 +258,16 @@
38 AC_SUBST(X11_CFLAGS)
39 AC_SUBST(X11_LIBS)
40
41-dnl Check for libXinerama headers and libraries.
42-PKG_CHECK_MODULES(XINERAMA, xinerama,[XINERAMA_FOUND=yes]
43- ,[XINERAMA_FOUND=no])
44-if test "x${XINERAMA_FOUND}" = xno
45-then
46- AC_MSG_ERROR([Could not find Xinerama - \
47- Try installing libXinerama-devel.])
48-fi
49-AC_SUBST(XINERAMA_CFLAGS)
50-AC_SUBST(XINERAMA_LIBS)
51+#dnl Check for libXinerama headers and libraries.
52+#PKG_CHECK_MODULES(XINERAMA, xinerama,[XINERAMA_FOUND=yes]
53+# ,[XINERAMA_FOUND=no])
54+#if test "x${XINERAMA_FOUND}" = xno
55+#then
56+# AC_MSG_ERROR([Could not find Xinerama - \
57+# Try installing libXinerama-devel.])
58+#fi
59+#AC_SUBST(XINERAMA_CFLAGS)
60+#AC_SUBST(XINERAMA_LIBS)
61
62 if test "x${ENABLE_XRENDER}" = "xyes"
63 then
64@@ -341,26 +341,26 @@
65 AC_CONFIG_FILES([tapset/jstack.stp])
66 fi
67
68-dnl Check for libpng headers and libraries.
69-PKG_CHECK_MODULES(LIBPNG, libpng,[LIBPNG_FOUND=yes]
70- ,[LIBPNG_FOUND=no])
71-if test "x${LIBPNG_FOUND}" = xno
72-then
73- AC_MSG_ERROR([Could not find libpng - \
74- Try installing libpng-devel.])
75-fi
76-AC_SUBST(LIBPNG_CFLAGS)
77-AC_SUBST(LIBPNG_LIBS)
78-
79-dnl Check for libXtst headers and libraries.
80-PKG_CHECK_MODULES(XTST, xtst,[XTST_FOUND=yes],[XTST_FOUND=no])
81-if test "x${XTST_FOUND}" = xno
82-then
83- AC_MSG_ERROR([Could not find Xtst - \
84- Try installing libXtst-devel.])
85-fi
86-AC_SUBST(XTST_CFLAGS)
87-AC_SUBST(XTST_LIBS)
88+#dnl Check for libpng headers and libraries.
89+#PKG_CHECK_MODULES(LIBPNG, libpng,[LIBPNG_FOUND=yes]
90+# ,[LIBPNG_FOUND=no])
91+#if test "x${LIBPNG_FOUND}" = xno
92+#then
93+# AC_MSG_ERROR([Could not find libpng - \
94+# Try installing libpng-devel.])
95+#fi
96+#AC_SUBST(LIBPNG_CFLAGS)
97+#AC_SUBST(LIBPNG_LIBS)
98+
99+#dnl Check for libXtst headers and libraries.
100+#PKG_CHECK_MODULES(XTST, xtst,[XTST_FOUND=yes],[XTST_FOUND=no])
101+#if test "x${XTST_FOUND}" = xno
102+#then
103+# AC_MSG_ERROR([Could not find Xtst - \
104+# Try installing libXtst-devel.])
105+#fi
106+#AC_SUBST(XTST_CFLAGS)
107+#AC_SUBST(XTST_LIBS)
108
109 dnl Check for freetype2 headers and libraries.
110 PKG_CHECK_MODULES(FREETYPE2, freetype2,[FREETYPE2_FOUND=yes]
111@@ -373,18 +373,18 @@
112 AC_SUBST(FREETYPE2_CFLAGS)
113 AC_SUBST(FREETYPE2_LIBS)
114
115-dnl Check for alsa headers and libraries (only required for Linux).
116-if test "x${BUILD_OS_DIR}" = "xlinux"
117-then
118- PKG_CHECK_MODULES(ALSA, alsa,[ALSA_FOUND=yes],[ALSA_FOUND=no])
119- if test "x${ALSA_FOUND}" = xno
120- then
121- AC_MSG_ERROR([Could not find alsa - \
122- Try installing alsa-lib-devel.])
123- fi
124-AC_SUBST(ALSA_CFLAGS)
125-AC_SUBST(ALSA_LIBS)
126-fi
127+#dnl Check for alsa headers and libraries (only required for Linux).
128+#if test "x${BUILD_OS_DIR}" = "xlinux"
129+#then
130+# PKG_CHECK_MODULES(ALSA, alsa,[ALSA_FOUND=yes],[ALSA_FOUND=no])
131+# if test "x${ALSA_FOUND}" = xno
132+# then
133+# AC_MSG_ERROR([Could not find alsa - \
134+# Try installing alsa-lib-devel.])
135+# fi
136+#AC_SUBST(ALSA_CFLAGS)
137+#AC_SUBST(ALSA_LIBS)
138+#fi
139
140 if test "x${enable_pulse_java}" = "xyes"
141 then