summaryrefslogtreecommitdiffstats
path: root/recipes-core/icedtea/icedtea6-native-1.7.5/icedtea-jdk-build-sizer-32-on-amd64.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/icedtea/icedtea6-native-1.7.5/icedtea-jdk-build-sizer-32-on-amd64.patch')
-rw-r--r--recipes-core/icedtea/icedtea6-native-1.7.5/icedtea-jdk-build-sizer-32-on-amd64.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-core/icedtea/icedtea6-native-1.7.5/icedtea-jdk-build-sizer-32-on-amd64.patch b/recipes-core/icedtea/icedtea6-native-1.7.5/icedtea-jdk-build-sizer-32-on-amd64.patch
new file mode 100644
index 0000000..3baeb5d
--- /dev/null
+++ b/recipes-core/icedtea/icedtea6-native-1.7.5/icedtea-jdk-build-sizer-32-on-amd64.patch
@@ -0,0 +1,36 @@
1Build the xawt sizer.32 binary on Linux/x86_64 so we can use it when
2compiling openjdk for 32-bit platforms.
3
4--- openjdk/jdk/make/sun/xawt/Makefile.orig 2011-01-08 01:53:22.000000000 -0500
5+++ openjdk/jdk/make/sun/xawt/Makefile 2011-01-11 15:12:17.000000000 -0500
6@@ -184,6 +184,22 @@
7
8 else # !solaris
9
10+ifeq ($(PLATFORM), linux)
11+
12+ifeq ($(ARCH), amd64)
13+# On amd64 we generate both 32 and 64-bit sizers in spite of ARCH_DATA_MODEL.
14+SIZERS = $(SIZER).32 $(SIZER).64
15+SIZERS_C = $(SIZER_32_C) $(SIZER_64_C)
16+SIZES = $(WRAPPER_GENERATOR_DIR)/sizes.32 $(WRAPPER_GENERATOR_DIR)/sizes.64
17+CFLAGS_32 = $(CFLAGS) -m32
18+else # !amd64
19+SIZERS = $(SIZER).32
20+SIZERS_C = $(SIZER_32_C)
21+SIZES = $(WRAPPER_GENERATOR_DIR)/sizes.32
22+endif # amd64
23+
24+else # !linux
25+
26 ifeq ($(ARCH_DATA_MODEL), 32)
27 SIZERS = $(SIZER).32
28 SIZERS_C = $(SIZER_32_C)
29@@ -194,6 +210,7 @@
30 SIZES = $(WRAPPER_GENERATOR_DIR)/sizes.64
31 endif # 32
32
33+endif # linux
34 endif # solaris
35
36 # XXX Hack for 6185483 - use hard-coded sizes.