summaryrefslogtreecommitdiffstats
path: root/recipes-core/icedtea/icedtea6-native-1.7.10/icedtea-fix-jar-path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/icedtea/icedtea6-native-1.7.10/icedtea-fix-jar-path.patch')
-rw-r--r--recipes-core/icedtea/icedtea6-native-1.7.10/icedtea-fix-jar-path.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-core/icedtea/icedtea6-native-1.7.10/icedtea-fix-jar-path.patch b/recipes-core/icedtea/icedtea6-native-1.7.10/icedtea-fix-jar-path.patch
new file mode 100644
index 0000000..c2f8df1
--- /dev/null
+++ b/recipes-core/icedtea/icedtea6-native-1.7.10/icedtea-fix-jar-path.patch
@@ -0,0 +1,29 @@
1# Backported from
2# HG changeset patch
3# User Xerxes R?nby <xerxes@zafena.se>
4# Date 1275385110 -7200
5# Node ID 7674917fa451a17a38b8cd6930068e8dc3b57b76
6# Parent cf45c29fbe48d2a0c543cbd6d03f4329010011c0
7Use full path to jar application to avoid relying on the one on the path.
8
92010-06-01 Xerxes R?nby <xerxes@zafena.se>
10
11 * Makefile.am:
12 (extra-lib/about.jar): Remove redundant
13 conditional that we don't need any more.
14 (rewrite-rhino.stamp): Use full path to
15 jar application to avoid relying on the one
16 on the path.
17
18diff -uNr icedtea6-1.7.3.orig/Makefile.am icedtea6-1.7.3/Makefile.am
19--- icedtea6-1.7.3.orig/Makefile.am 2010-03-31 23:34:07.000000000 +0200
20+++ icedtea6-1.7.3/Makefile.am 2010-07-14 16:52:45.000000000 +0200
21@@ -1749,7 +1744,7 @@
22 stamps/rewrite-rhino.stamp: stamps/rewriter.stamp $(RHINO_JAR)
23 if WITH_RHINO
24 mkdir -p rhino/rhino.{old,new}
25- (cd rhino/rhino.old ; jar xf $(RHINO_JAR))
26+ (cd rhino/rhino.old ; $(ICEDTEA_BOOT_DIR)/bin/jar xf $(RHINO_JAR))
27 $(ICEDTEA_BOOT_DIR)/bin/java -cp $(abs_top_builddir)/rewriter \
28 com.redhat.rewriter.ClassRewriter \
29 $(abs_top_builddir)/rhino/rhino.old $(abs_top_builddir)/rhino/rhino.new \