summaryrefslogtreecommitdiffstats
path: root/recipes-core/ecj/ecj-initial.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/ecj/ecj-initial.bb')
-rw-r--r--recipes-core/ecj/ecj-initial.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-core/ecj/ecj-initial.bb b/recipes-core/ecj/ecj-initial.bb
new file mode 100644
index 0000000..45317a6
--- /dev/null
+++ b/recipes-core/ecj/ecj-initial.bb
@@ -0,0 +1,32 @@
1# ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
2# and no less features.
3
4# This variant runs on the initial (not Java5-compatible runtime).
5
6DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
7HOMEPAGE = "http://www.eclipse.org/"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
10
11DEPENDS = "libecj-bootstrap"
12
13SRC_URI = "file://ecj-initial.in"
14
15S = "${WORKDIR}"
16
17inherit native
18
19JAR = "ecj-bootstrap.jar"
20
21do_compile() {
22 # Create the start script
23 echo "#!/bin/sh" > ecj-initial
24 echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-initial
25 echo "RUNTIME=java-initial" >> ecj-initial
26 cat ecj-initial.in >> ecj-initial
27}
28
29do_install() {
30 install -d ${D}${bindir}
31 install -m 755 ${S}/ecj-initial ${D}${bindir}
32}