summaryrefslogtreecommitdiffstats
path: root/recipes-core/ecj/ecj-bootstrap-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/ecj/ecj-bootstrap-native.bb')
-rw-r--r--recipes-core/ecj/ecj-bootstrap-native.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-core/ecj/ecj-bootstrap-native.bb b/recipes-core/ecj/ecj-bootstrap-native.bb
new file mode 100644
index 0000000..df05be5
--- /dev/null
+++ b/recipes-core/ecj/ecj-bootstrap-native.bb
@@ -0,0 +1,38 @@
1# ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
2# and no less features.
3#
4# This recipe uses the jar created by libecj-bootstrap.
5
6DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
7HOMEPAGE = "http://www.eclipse.org/"
8SECTION = "devel"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
11 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420 \
12 "
13
14DEPENDS = "libecj-bootstrap virtual/java-native"
15
16PROVIDES = "virtual/javac-native"
17
18SRC_URI = "file://ecj.in"
19
20S = "${WORKDIR}"
21
22JAR = "ecj-bootstrap.jar"
23
24inherit native
25
26do_compile() {
27 # Create the start script
28 echo "#!/bin/sh" > ecj-bootstrap
29 echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-bootstrap
30 echo "RUNTIME=java" >> ecj-bootstrap
31 cat ecj.in >> ecj-bootstrap
32}
33
34do_install() {
35 install -d ${D}${bindir}
36 install -m 755 ${S}/ecj-bootstrap ${D}${bindir}
37 install -m 755 ${S}/ecj-bootstrap ${D}${bindir}/javac
38}