summaryrefslogtreecommitdiffstats
path: root/recipes-core/classpathx/inetlib_1.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/classpathx/inetlib_1.1.1.bb')
-rw-r--r--recipes-core/classpathx/inetlib_1.1.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-core/classpathx/inetlib_1.1.1.bb b/recipes-core/classpathx/inetlib_1.1.1.bb
new file mode 100644
index 0000000..862b730
--- /dev/null
+++ b/recipes-core/classpathx/inetlib_1.1.1.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "A Java library of clients for common internet protocols"
2AUTHOR = "GNU Classpath"
3HOMEPAGE = "http://gnu.org/software/classpath/inetlib.html"
4LICENSE = "GPL+libraryexception"
5LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
6
7SRC_URI = "http://ftp.gnu.org/gnu/classpath/${BP}.tar.gz \
8 file://datadir_java.patch \
9 "
10
11inherit java-library autotools
12
13JPN = "libgnuinet-java"
14
15export JAVAC = "javac"
16
17export JAVA = "java"
18
19# We fake this, it is not neccessary anyway.
20export JAVADOC = "true"
21
22do_compile() {
23 oe_runmake JARDIR=${datadir_java} inetlib_jar=${JARFILENAME}
24}
25
26SRC_URI[md5sum] = "aaa24be4bc8d172ac675be8bdfa636ee"
27SRC_URI[sha256sum] = "1b078a39e022f86e4e2c8189b4d2789a5da414e8f1cb285587b7800b950a44de"
28
29NATIVE_INSTALL_WORKS = "1"
30BBCLASSEXTEND = "native"
31