summaryrefslogtreecommitdiffstats
path: root/recipes-core/classpathx/gnujaf_1.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/classpathx/gnujaf_1.1.1.bb')
-rw-r--r--recipes-core/classpathx/gnujaf_1.1.1.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-core/classpathx/gnujaf_1.1.1.bb b/recipes-core/classpathx/gnujaf_1.1.1.bb
new file mode 100644
index 0000000..2c055bb
--- /dev/null
+++ b/recipes-core/classpathx/gnujaf_1.1.1.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "Provides a mean to type data and locate components suitable for performing various kinds of action on it."
2AUTHOR = "GNU ClasspathX"
3LICENSE = "GPL+libraryexception"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
5
6SRC_URI = "http://ftp.gnu.org/gnu/classpathx/activation-${PV}.tar.gz \
7 file://datadir_java.patch \
8 "
9
10inherit autotools java-library
11
12S = "${WORKDIR}/activation-${PV}"
13
14export JAVAC = "javac"
15
16# Fake javadoc
17export JAVADOC = "true"
18
19JARFILENAME = "activation-${PV}.jar"
20ALTJARFILENAMES = "activation.jar gnujaf.jar"
21
22do_compile() {
23 mkdir -p build
24
25 javac -sourcepath source -d build `find source -name "*.java"`
26
27 fastjar -C build -c -f ${JARFILENAME} .
28}
29
30SRC_URI[md5sum] = "de50d7728e8140eb404f2b4554321f8c"
31SRC_URI[sha256sum] = "b1b5ef560d30fcb11fbf537246857d14110ce4eb2b200d4c54690472305d87b7"
32
33NATIVE_INSTALL_WORKS = "1"
34BBCLASSEXTEND = "native"
35